Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Can not select key message

Hi, my name is Juan Carlos Torres and work for a Cisco distributor.

We recieved a PIX515 that have presented the next error:

assertion "1port||fport" failed:file"xlate.c", line 1075 thread name: pix/intf1(old pc 0x80078e6b ebp

0x80CI35F8)

I investigated the error but couldn't find any related information, so I powered on the equipment and it worked fine for a long while, so I decided to upgrade software version.

I upgraded to version 6.3(2) from 6.0 and now after boot up I recive the message "Can not select private key" before the "Type ? for a list of available commands" message. I tried to downgrade version to 6.1 but now I can't !!! I recieve the message Timed out during transfer.

Is there anybody that can help me ???, does anybody knows what the "Can not select private key" message means ??? Tnks !!!

1 REPLY
Cisco Employee

Re: Can not select key message

The message usually indicates the PIX has a private/public key pair generated internally, but since it was generated the config has been changed (usually a different IP address on an interface), making the key pair invalid.

To get rid of the message just zeroize your key and generate a new pair with:

> conf t

> ca zeroize rsa

> ca generate rsa key 512

After this you shouldn't see the message anymore.

88
Views
0
Helpful
1
Replies
CreatePlease to create content