Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

can't have access +RDP in VPN PIX

Hi to all expert out there!!

I have configured a PIX 501 VPN serverto be able to accept VPN connection, here are the following PIX settings:

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxx encrypted

passwd xxxxx encrypted

hostname pare-feu-xxx

domain-name xxx.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

no fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

name 192.168.1.3 srv-xxx-02

access-list externe permit tcp any any eq smtp

access-list externe permit tcp any any eq https

access-list externe permit tcp any any eq www

access-list nonat permit ip 192.168.1.0 255.255.255.0 10.1.2.0 255.255.255.0

pager lines 24

icmp permit any inside

mtu outside 1500

mtu inside 1500

ip address outside pppoe setroute

ip address inside 192.168.1.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool VPNPOOL 10.1.2.1-10.1.2.10

pdm location 192.168.1.0 255.255.255.0 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 192.168.1.0 255.255.255.0 0 0

static (inside,outside) tcp interface smtp srv-xxx-02 smtp netmask 255.255.255.2

55 0 0

static (inside,outside) tcp interface https srv-xxx-02 https netmask 255.255.255

.255 0 0

static (inside,outside) tcp interface www srv-xxx-02 www netmask 255.255.255.255

0 0

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server RADIUS (inside) host srv-xxx-02 radius_key timeout 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community Syn-001

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set csaset esp-3des esp-md5-hmac

crypto dynamic-map csamap 10 set transform-set csaset

crypto map csa 10 ipsec-isakmp dynamic csamap

crypto map csa client authentication RADIUS

crypto map csa interface outside

isakmp enable outside

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup VPNHOSTS! address-pool VPNPOOL

vpngroup VPNHOSTS! dns-server srv-xxx-02

vpngroup VPNHOSTS! wins-server srv-xxx-02

vpngroup VPNHOSTS! default-domain xxxx.com

vpngroup VPNHOSTS! split-tunnel nonat

vpngroup VPNHOSTS! idle-time 1800

vpngroup VPNHOSTS! password ********

telnet 192.168.1.0 255.255.255.0 inside

telnet timeout 5

ssh 0.0.0.0 0.0.0.0 outside

ssh 192.168.1.0 255.255.255.0 inside

ssh timeout 5

console timeout 0

vpdn group csa request dialout pppoe

vpdn group csa localname xxxxxxxxx

vpdn group csa ppp authentication pap

vpdn username xxxxxxx password *********

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

terminal width 80

So i'm able to connect in VPN client but i can't remote desktop to my server:

when i do term mon + loging mon 7 option

i get the following error:

305005: No translation group found for tcp src outside:10.1.2.1/1669 dst inside:srv-ofm-02/3389

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: can't have access +RDP in VPN PIX

with the current config:

global (outside) 1 interface

nat (inside) 1 192.168.1.0 255.255.255.0 0 0

the command "nat 0" is missing in order to disable natting for traffic destined for the vpn client.

e.g.

nat (inside) 0 access-list nonat

2 REPLIES
Gold

Re: can't have access +RDP in VPN PIX

with the current config:

global (outside) 1 interface

nat (inside) 1 192.168.1.0 255.255.255.0 0 0

the command "nat 0" is missing in order to disable natting for traffic destined for the vpn client.

e.g.

nat (inside) 0 access-list nonat

New Member

Re: can't have access +RDP in VPN PIX

You are missing a statment to map a 192.168.x.x address to a 10.1.2.x address.This haapens because your vpn pool address are differnet from your internal address.

154
Views
0
Helpful
2
Replies
CreatePlease login to create content