Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot add CAS into CAM

Let me expalin first what i have done.

I have changed the IP addresses in the NAS and Nam from 192.168.12.2 and 192.168.20.2

Primary Nas 172.18.13.4

Secondaru Nas 172.18.13.3

Servive IP 172.18.13.2

Primary NAM 172.18.15.2

Secondary NAM 172.15.3

Service IP 172.18.15.4

Failover is configured tested through cli and its working.

Now when i add NAS into NAM, The primary NAS lost its connectivity and is unreachable. Even after logging into the NAS through CLI, I am unable to reach its the gateway which in our case is the Ip address of core switch SVI. However the secondary NAS is reachable.

I have tried linux commands like service network restart but it does not work. I suspect that there would be some files where we have to change the IP addresses aslo. For CAS failover interface eth2, when i set the the ip address , it is effective untl i reload.

Now how to move forward.

or do we have to restore the default configuration of NAS and NAM and do it from the scrath. and how can we do that.

2 REPLIES
New Member

Re: Cannot add CAS into CAM

You should check some info as below:

- check secret password between CAS and CAM (in cli, try "cat /root/.secret"). The secret password should be the same on both CAS, CAM.

- try to regenerate the certs on both CAS, CAM

- reboot CAS, CAM and check if the ip of CAS, CAM has been changed correctly (in cli, try "ip add"

Let me know your results!

Regards,

namNT

New Member

Re: Cannot add CAS into CAM

I have tried changing the IP address through service perfigo config. I restarted the machines and checked the shared secret key in the cat /root/.secret file they all match exactly the same. i have regenerATED THE CERT again. my failover is working and tested by ./foistate.sh command.

I have connected the NAs ethernet 0 and 1 interface to the switch. i have configured the trunk link allowed the management vlan no. when i add the nas service ip immedialtely nas looses connectivity after adding it into cam. However i removed nas ethernet 1 interface and then tried to add it . it started working but as soon as i connected the other interface it again stopped . the secondary NAS started pinging and primary was request timed out. then again you have to reload.

i make a native dummy vlan 999 on ethernet0 of nas and vlan 998 on nas ethernet1 it shows me native vlan mismatch error. what could be the error.

how can i assign the permanent ip address to ethernet2 which is used for HA. when ever i reload it it loses its ip addresses.

140
Views
0
Helpful
2
Replies
CreatePlease login to create content