Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco PIX ASDM - Help

Hi all,

i have a pix 515E and i try to configure access to ASDM tool.

This is my config:

http server enable

http 192.168.149.4 255.255.255.255 inside

I have tried to access at PIX address : https://192.168.149.3/startup.html

but after prompt login i received a error 404 from internet explorer.

WHY?

Thanks

7 REPLIES
Gold

Re: Cisco PIX ASDM - Help

I presume, that the PC/Laptop that you are initiating the ASDM access from is IP 192.168.149.4?? As you have given access to the ASDM only from this IP.

Try changing the ASDM access to any client on the inside and see if this resolves your problem i.e.

http server enable

http 192.168.149.0 255.255.255.0 inside

Let me know how you get on.

Jay

New Member

Re: Cisco PIX ASDM - Help

Hi,

i have tried to change configuration, but i received same error.

How to know if my pix supports asdm? How to know if asdm is installed into my pix?

Please help me!

Thanks a lot

Gold

Re: Cisco PIX ASDM - Help

Issue: sho ver

And post back the result - take out any sensitive info.

Gold

Re: Cisco PIX ASDM - Help

asdm works with pix v7 not v6.x.

when i was trying asdm, i type in https:///admin

also even asdm is not installed, pdm should still be there for v6.x.

New Member

Re: Cisco PIX ASDM - Help

This is my sh ver:

Cisco PIX Security Appliance Software Version 7.0(2)

Compiled on Fri 15-Jul-05 22:55 by builders

System image file is "flash:/pix702.bin"

Config file at boot was "startup-config"

IperPIX up 10 mins 22 secs

Hardware: PIX-515E, 128 MB RAM, CPU Pentium II 433 MHz

Flash E28F128J3 @ 0xfff00000, 16MB

BIOS Flash AM29F400B @ 0xfffd8000, 32KB

5)

0: Ext: Ethernet0 : address is 0009.b75f.857b, irq 10

1: Ext: Ethernet1 : address is 0009.b75f.857c, irq 11

Licensed features for this platform:

Maximum Physical Interfaces : 6

Maximum VLANs : 25

Inside Hosts : Unlimited

Failover : Active/Active

VPN-DES : Enabled

VPN-3DES-AES : Disabled

Cut-through Proxy : Enabled

Guards : Enabled

URL Filtering : Enabled

Security Contexts : 2

GTP/GPRS : Disabled

VPN Peers : Unlimited

This platform has an Unrestricted (UR) license.

I have tried to connect at http://mypix/admin but i receiv only the request of certificate like ever and then error 404 Page not found.

Thanks,

I wait a response, please.

New Member

Re: Cisco PIX ASDM - Help

the problem seems to be that asdm is maybe not installed on ur pix.Chk via show flash command.U will also get to know abt whether pdm is installed in ur pix.

. Also chk whether u r able to open via normal HTTPS://x.x.x.x method.incase PDM is installed pls be sure abt jre version.

Cisco Employee

Re: Cisco PIX ASDM - Help

Try the following and see if that resolves the issue:

1.) Issue "show version" command and see if ASDM v5.x is installed.

2.) If you see ASDM installed, then verify if you have specified it in the config:

Steps:

pixfirewall(config)#dir

This command would display all the contents in PIX Flash Filesystem. Make a note of ASDM filename and location.

pixfirewall(config)#asdm image flash:

pixfirewall(config)#http server enable

pixfirewall(config)#http 0 0 inside

After entering the above info try.

If this does'nt help open up a TAC Service Request.

Cheers...

Prashant Chauhan

486
Views
0
Helpful
7
Replies
CreatePlease to create content