Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CLI SigUpdate on the Sensor 3.1(3) S44

Dear experts,

I'm trying to update the Signature version from S42 to S44 on the IDS-4230-FE using the automatic updator through CLI.

I put the update file in "/usr/nr/update/".

In the directory of "/usr/nr/bin",

I input " ./idsupdate netrangr@123.456.789.012/update PASSWD 2 17:30"

when I wanted it to start at 17:30 Tuesday.

It looks like it'd be scheduled fine, but even 3 hours later, nothing happens.

"./idsupdate show" gives me it IS scheduled to update.

"/usr/nr/update/IDS-sig-3.1-3-S44.bin -I"

works fine, ofcourse, but I'm need to install automatically...

What I confirmed before the installation were these.

1. The update filename is correct and the size is correct.

2. chmoded +x (just in case).

3. The sytem date is correct.

4. Current version is S42 and is running O.K.

I tried on some sensors and this didn't work at all, but one.

After this, I checked if the sensor can FTP itself and found that the only one

which worked could. (the others returned code:421, while FTP with Director works fine)

Now I'm curious if there's a way to use this automatic updator without

using FTP.

Since our connection is very narrow and unstable, FTP at the scheduled time is out of our option.

Or will this be solved in the version 4?

Web Interface is also out of our option.

#I know it is useful but I'm not the one to decide. :(

Oh by the way, in the NSDB's "What's new", there's a new SIG 1300,

but it's not in the packetd.conf nor "IDS-sig-3.1-3-S44.readme.txt".

Anyone aware of this?

1 REPLY
Cisco Employee

Re: CLI SigUpdate on the Sensor 3.1(3) S44

Hi Kentanu,

Unfortunately ftp is only the automatic update method provided with the 3.1 version of the ids appliance to download signatures and service pack. Having said that I would like to confirm the the type of ftp server that your are trying as the following are the only types being supported and tested with the IDS appliance

--Sambar FTP Server Version 5.0 (win32)

--Web-mail Microsoft FTP Service Version 5.0 (win32)

--Serv-U FTP-Server v2.5h for WinSock (win32)

--Solaris 2.8

--HP-UX (HP-UX qdir-5 B.10.20 A 9000/715)

--Windows 2000 (Microsoft ftp server version 5.0)

--Windows NT 4.0 (Microsoft ftp server version 3.0)

So please make sure your server is among one of the above otherwise you might see the problems happening with the download every now and then.

Hope the above will help

Thanks

Zia

85
Views
0
Helpful
1
Replies
CreatePlease to create content