Cisco Support Community
Community Member

cofiguring PIX506 via PDM for mail smtp routing

We have a pix506e device connected to a router via ethernet. We have a mail server on the internal network ( and the PIX is acting as a DHCP for the internal network. the PIX gets an external address from the DHCP on the router (192.168.2.x) the router has a static IP address for ISP connection. I have configured a rule on the router to allow all traffic to pass to the firewall. I have then configured a rule to allow all hosts on the external interface using SMTP to route to the mail server on (or at least I thought I had). This configuration doesn't appear to allow the smtp server to be visible to the internet for open relay testing etc.

Do I need to configure multiple static IPs for the firewall/router/mail server to get this to work?

PS I am configuring via PDM

Any suggestions would be appreciated


Re: cofiguring PIX506 via PDM for mail smtp routing


try somethin like this:


ip nat inside source static tcp 25 interface int-of-router-to-isp 25

access-list 100 permit tcp any any eq smtp

apply the access-list to the interface connecting to the isp.


static (inside,outside) netmask 0 0

access-list allow_in permit tcp any host eq smtp

apply this access list to the outside interface of the pix.

you might need to turn off fixup for smtp depending on the version of mail server you are running

I have used as an example. choose and ip that is not in the dhcp scope.

Let me know if this helps, otherwise post your configs and we can troubleshoot them

Community Member

Re: cofiguring PIX506 via PDM for mail smtp routing


Should have said that the router isn't a cisco.

But that bit seems to be working allright logs show the traffic being passed to PIX outside interface.

configs are as follows:

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxx encrypted

passwd xxxxx encrypted

hostname pixfirewall


fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69


access-list inside_outbound_nat0_acl permit ip any

access-list outside_cryptomap_dyn_20 permit ip any

access-list outside_access_in remark smtp all rule

access-list outside_access_in permit tcp any eq smtp any eq smtp

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute

ip address inside

ip audit info action alarm

ip audit attack action alarm

ip local pool vpn

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0 0

access-group outside_access_in in interface outside

route outside 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20

crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map interface outside

isakmp enable outside

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

vpngroup nyfvo address-pool vpn

vpngroup nyfvo idle-time 1800

vpngroup nyfvo password ********

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address inside

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

dhcpd enable inside

terminal width 80


CreatePlease to create content