Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

configure SubInterface on ASA5510

Hello,

Currently I am using Pix515e with 2 physical interfaces by configuring sub interface as below:

interface ethernet0 100full

interface ethernet0 vlan2 physical

interface ethernet0 vlan3 logical

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

nameif vlan3 visa security50

Please Note: Outside interface of the pix connect to port1(trunking assign) on a swtich2950 and Port2(VLAN2 assign) connect to a cisco router and Port3(VLAN3 assign) connect to another switch2950.

Now I am planning to use ASA5510, so how can assign the interface of ASA to be the same vlan logical interface as pix.

interface Ethernet0/0

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/1

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

Any feed back and solution is appreciated

Regards,

Vin

4 REPLIES
New Member

Re: configure SubInterface on ASA5510

Vin,

This is the section I used when configuring sub-ints on my ASA 5520.... take a look its fairly simple but a little bit different then the pix setup.

http://www.cisco.com/en/US/products/ps6120/products_configuration_guide_chapter09186a008054d463.html

Good luck,

Chris

Bronze

Re: configure SubInterface on ASA5510

Here is an example of how you can do subinterfaces on the asa:

interface GigabitEthernet0/1.2

description [Switch Mgmt.]

vlan 2

nameif Switch

security-level 100

ip address 1.1.1.1 255.255.255.252

Hope this helps.

New Member

Re: configure SubInterface on ASA5510

Hello Sean,

Your above sample is to configuration Vlan2 for sub interface, so now i have vlan3 config as you see in my previous post. So can you tell me how to configure that?

Please note: The interface configuration on the pix are the existing Pix 515e in my network. But now i can't change. coz we have two VLANs need to config.

Regards,

Vin

New Member

Re: configure SubInterface on ASA5510

Vin,

To set up your vlan3 just follow Seans post but instead of putting "vlan2" just put vlan3 and change the interface address and description.

interface GigabitEthernet0/1.3

description [Logical]

vlan 3

nameif Switch

security-level 100

ip address x.x.x.x 255.255.255.255

Good luck,

Chris

272
Views
0
Helpful
4
Replies
CreatePlease to create content