Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

configure vpn

I am using a cisco 1751 vpn router to connect to a concentrator located in overseas. The configuration are as follow.

ethernet port

ip address 10.10.10.1 255.255.255.0

ip address 202.90.90.200 255.255.255.224 secondary

serial port

192.168.10.10 255.255.255.252

I need to connect to the concentrator, can I set the peer address on the concentrator to my router's ethernet secondary port - 202.90.90.200, is there any restrictions that peer address must be on the serial port.

How about crypto map, can I set it on the ethernet port ?

Pls advice

3 REPLIES
Bronze

Re: configure vpn

Hi,

u can use any routable ip address configured on any of the interface of the router, use:

crypto map local-address

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122tcr/122tsr/fipsencr/sftipsec.htm#1018189

Thanks,

Afaq

New Member

Re: configure vpn

interface Serial0/0

description connected to Internet

mtu 1492

ip address 192.168.10.10 255.255.255.252

ip nat outside

interface FastEthernet0/0

description connected to EthernetLAN

ip address 192.168.100.1 255.255.255.0

ip address 202.202.20.20 255.255.255.224 secondary

ip nat inside

speed auto

crypto map vpn

!

ip route 0.0.0.0 0.0.0.0 serial0/0

ip nat inside source list 1 interface serial0/0 overload

ip classless

I have crypto map to my ethernet port as the above config but still cannot ping to the concentrator. Can you pls advice.

Cisco Employee

Re: configure vpn

Put the crypto map on the outgoing port, which is s0/0 from what I can tell. Then use the command:

> crypto map vpn local-address fa0/0

This will tell the router to use the IP address of the fa0/0 interface as the source address in all it's communication with the concentrator. The peer address set in the concentrator will also have to be this address, not 192.168.10.10.

Also, you'll have to make the 202.202.20.20 address the primary address on the fa0/0 interface, that's the only address the router will use. So make your config look like:

interface FastEthernet0/0

description connected to EthernetLAN

ip address 192.168.100.1 255.255.255.0 secondary

ip address 202.202.20.20 255.255.255.224

101
Views
0
Helpful
3
Replies