Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuring a DMZ on ASA 5505

I have a Cisco ASA 5505 that I am trying to configure a web server on a DMZ. I have the DMZ interface working, but I am not able to get access from to the server connected to the DMZ interface. I have been looking for a week now on google, but haven't come across the setup...

I have the following interfaces (not using real ips)..

WAN - 123.123.100.1

LAN - 192.168.0.1

DMZ - 172.16.8.1 - port 7

Webserver - 172.16.8.2 plugged into port 7

ASA version 8.2(5)

I am looking to have access to the webserver from the inside via RDP, and access to customers from the outside over 80. This also needs to communicate to a DB server located at another facility through a VPN.

Any help would be appreciated. I have been pulling my hair out on this one.

Thanks 

Mike

  • Other Security Subjects
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Generally speaking inside to

Generally speaking inside to DMZ is allowed by default. If you have any access-list applied to your inside interface you would need to add the entry for the DMZ server address over tcp/3389 (rdp).

Incoming outside traffic would need both a static NAT entry and access-list.

Web server to remote site via VPN would need the DMZ-remote network addresses defined in the access-list reference by the cryptomap used by the VPN. You'd also generally need a NAT exemption for that traffic.

Each of those are common use cases for an ASA. If you can share a sanitized version of your running configuration, we could possibly see what's missing.

6 REPLIES
Hall of Fame Super Silver

Generally speaking inside to

Generally speaking inside to DMZ is allowed by default. If you have any access-list applied to your inside interface you would need to add the entry for the DMZ server address over tcp/3389 (rdp).

Incoming outside traffic would need both a static NAT entry and access-list.

Web server to remote site via VPN would need the DMZ-remote network addresses defined in the access-list reference by the cryptomap used by the VPN. You'd also generally need a NAT exemption for that traffic.

Each of those are common use cases for an ASA. If you can share a sanitized version of your running configuration, we could possibly see what's missing.

New Member

Thanks for the quick reply

Thanks for the quick reply Marvin. After you verified the incoming outside traffic needing the NAT and ACL, I looked those over again, and found the problem. I was able to get the RDP to the server on the DMZ port working. Still need to put in the WWW access, but there is an HTTP redirection that keeps taking me to the ASA ASDM load page. I am guessing that I just need to remove 'http 0.0.0.0 0.0.0.0 outside' from the config and that should take care of it? Here is the scrubbed config. I know it's probably messy. The person that set this up used the ASDM.  Thanks, Mike

Result of the command: "sh run"

: Saved
:
ASA Version 8.2(5) 
!
hostname ISC-P2-ASA
enable password 8Ryt7RU24 encrypted
passwd 2KFbdI.2KYOU encrypted
names
name 192.168.9.0 OKC_LAN
name 192.168.1.0 P10_LAN
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
 switchport access vlan 12
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.125 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 123.123.100.1 255.255.255.0 
!
interface Vlan12
 description DMZ for web server
 no forward interface Vlan1
 nameif DMZ
 security-level 50
 ip address 172.16.8.1 255.255.255.0 
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
object-group network DMZ_outside
object-group network net-local
access-list PIM_ACCPTREG_ACL extended permit ip any 192.168.0.64 255.255.255.192 
access-list ISCClient_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0 
access-list ISCVPN_splitTunnelAcl standard permit 192.168.0.64 255.255.255.192 
access-list inside_nat0_outbound extended permit ip 192.168.0.64 255.255.255.192 192.168.0.240 255.255.255.240 
access-list inside_nat0_outbound extended permit ip any 192.168.0.240 255.255.255.240 
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 host OKC_LAN 
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 OKC_LAN 255.255.255.0 
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 P10_LAN 255.255.255.0 
access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 OKC_LAN 255.255.255.0 
access-list outside_1_cryptomap extended permit ip 172.16.8.0 255.255.255.0 OKC_LAN 255.255.255.0 
access-list outside_2_cryptomap extended permit ip 192.168.0.0 255.255.255.0 P10_LAN 255.255.255.0 
access-list DMZ_fromOutside extended permit tcp any host 123.123.100.1 eq 3389 
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu DMZ 1500
ip local pool VPN 192.168.0.240-192.168.0.250 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 192.168.0.0 255.255.255.0
nat (inside) 10 0.0.0.0 0.0.0.0
static (DMZ,outside) tcp interface 3389 172.16.8.2 3389 netmask 255.255.255.255 
access-group DMZ_fromOutside in interface outside
route outside 0.0.0.0 0.0.0.0 123.123.100.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL 
aaa authentication http console LOCAL 
http server enable
http 192.168.0.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 71.198.75.152 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set pfs group1
crypto map outside_map 2 set peer 18.16.38.122 
crypto map outside_map 2 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130 
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117 
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b 
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504 
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72 
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56 
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043 
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31 
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b 
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20 
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65 
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420 
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329 
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365 
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7 
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597 
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10 
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc 
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b 
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845 
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8 
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced 
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f 
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201 
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868 
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101 
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8 
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777 
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a 
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406 
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973 
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403 
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969 
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b 
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973 
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30 
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603 
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355 
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609 
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80 
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e 
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a 
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc 
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16 
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0 
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8 
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28 
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
telnet timeout 5
ssh 192.168.0.0 255.255.255.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy ISCVPN internal
group-policy ISCVPN attributes
 dns-server value 8.8.4.4 8.8.8.8
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value ISCClient_splitTunnelAcl
username admin password auOX79JYgMQFmUCa encrypted privilege 15
username ISC1 password jyI8qcEECr3DDCto encrypted privilege 0
username ISC1 attributes
 vpn-group-policy ISCVPN
username clickreply password 6vbo7voe2vWXrjAM encrypted privilege 0
username clickreply attributes
 vpn-group-policy ISCVPN
tunnel-group ISCVPN type remote-access
tunnel-group ISCVPN general-attributes
 address-pool VPN
 default-group-policy ISCVPN
tunnel-group ISCVPN ipsec-attributes
 pre-shared-key *****
tunnel-group 71.198.75.152 type ipsec-l2l
tunnel-group 71.198.75.152 ipsec-attributes
 pre-shared-key *****
tunnel-group 18.16.38.122 type ipsec-l2l
tunnel-group 18.16.38.122 ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect ip-options 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:59a026f94de9b92f31969d578eb9528f
: end

Hall of Fame Super Silver

If your outside subnet is a

If your outside subnet is a /24, you would typically use an address other than the interface for the server(s) you want to be accessed from outside.

Assuming you can do that (since you already have RDP setup from outside), you would add a second entry to your DMZ ACL and a make your static NAT apply to all ports - e.g.:

access-list DMZ_fromOutside extended permit tcp any host 123.123.100.2 eq 80

static (DMZ,outside) tcp 123.123.100.2 172.16.8.2 netmask 255.255.255.255

 

 

New Member

Thanks for the info Marvin.

Thanks for the info Marvin. After some time last night, I was able to get the following working...

Outside to DMZ via port 3389

Outside to DMZ via port WWW

DMZ to Outside for internet browsing

 

I am still having issues getting the DMZ to talk to the DB server on the other side of the OKC_LAN VPN, and inside to DMZ.

Hall of Fame Super Silver

Re the VPN, you have the DMZ

Re the VPN, you have the DMZ subnet in the access-list used by the cryptomap:

access-list outside_1_cryptomap extended permit ip 172.16.8.0 255.255.255.0 OKC_LAN 255.255.255.0

..but you don't have a NAT exemption for it.

For inside to DMZ, do the clients use the ASA as their gateway? If so, it should work. You can check the firewall handling of that flow with:

packet-tracer input inside tcp 192.168.0.1 1025 172.16.18.2 80 detailed

New Member

I was able to get everything

I was able to get everything working. You pointed me in the right direction. I appreciate the help.

It ended up being ACL's that took care of most of it.

Thanks

268
Views
0
Helpful
6
Replies