Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Could something be wrong with my pix? Please help!!

I have a faily basic config here, and I can't get it to work :(

I have a couple Citrix servers, web, and a mail server behind my pix. They all have static ip's, so, I want to nat them at the firewall to re-direct to my internal servers. Here is my config (Ip address's changed for security reasons)

Can anyone here see if I'm missing anything? It's driving me crazy!!

PIX Version 6.3(1)

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxxx

passwd xxxxxx

hostname firewall

domain-name somecompany.com

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

names

access-list nonat permit ip 192.168.100.0 255.255.255.0 192.168.200.0 255.255.255.0

access-list 151 permit ip 192.168.100.0 255.255.255.0 192.168.200.0 255.255.255.0

access-list inbound permit tcp any host 207.229.61.2 eq www

access-list inbound permit tcp any host 207.229.61.2 eq ssh

access-list inbound permit tcp any host 207.229.61.3 eq smtp

access-list inbound permit tcp any host 207.229.61.3 eq www

access-list inbound permit tcp any host 207.229.61.4 eq citrix-ica

access-list inbound permit tcp any host 207.229.61.5 eq citrix-ica

access-list inbound permit tcp any host 207.229.61.5 eq 3389

access-list inbound permit tcp any host 207.229.61.6 eq www

access-list inbound permit tcp any host 207.229.61.6 eq citrix-ica

access-list inbound permit tcp any host 207.229.61.6 eq 3389

access-list inbound permit tcp any host 207.229.61.7 eq www

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.x 255.255.255.224

ip address inside 192.168.100.86 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool VPNPOOL 192.168.200.20-192.168.200.40

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list nonat

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp 207.229.61.2 www 192.168.100.138 www netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.2 ssh 192.168.100.138 ssh netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.3 smtp 192.168.100.16 smtp netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.3 www 192.168.100.16 www netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.4 citrix-ica 192.168.100.11 citrix-ica netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.5 citrix-ica 192.168.1.3 citrix-ica netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.5 3389 192.168.1.3 3389 netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.6 www 192.168.100.18 www netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.6 citrix-ica 192.168.100.18 citrix-ica netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.6 3389 192.168.100.18 3389 netmask 255.255.255.255 0 0

static (inside,outside) tcp 207.229.61.7 www 192.168.0.67 www netmask 255.255.255.255 0 0

access-group inbound in interface outside

route outside 0.0.0.0 0.0.0.0 207.229.61.161 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 192.168.100.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set CLIENT esp-3des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set CLIENT

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap client configuration address initiate

crypto map mymap client configuration address respond

crypto map mymap interface outside

isakmp enable outside

isakmp key ******** address 0.0.0.0 netmask 0.0.0.0

isakmp identity address

isakmp client configuration address-pool local VPNPOOL outside

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup LOGICORP address-pool VPNPOOL

vpngroup LOGICORP dns-server 192.168.100.14

vpngroup LOGICORP wins-server 192.168.100.14

vpngroup LOGICORP idle-time 7200

vpngroup LOGICORP password ********

vpngroup dns idle-time 1800

telnet timeout 5

ssh 192.168.100.0 255.255.255.0 inside

ssh timeout 60

console timeout 0

username xxx password xxxxx

terminal width 80

Cryptochecksum:xxx

: end

8 REPLIES
New Member

Re: Could something be wrong with my pix? Please help!!

My first view, quickly.

Check your outside IP address or your gateway address, it seems they are not on the same subnet.

Outside IP: 207.229.61.150

Default Gateway: 207.229.61.161

With mask of .224, the IP bounderies are:

0-31

32-63

64-95

96-127

128-159

160-191

...

Perhaps your default gateway should be .151

Regards

Ben

New Member

Re: Could something be wrong with my pix? Please help!!

Hi Ben,

Good eye, but, the address's are in the same range. I changed them around a bit in the config I posted for security reasons ;)

New Member

Re: Could something be wrong with my pix? Please help!!

Both Nat statements seem wrong to me.

There is no need for the no-nat statements. In fact I wouldn't be surprised if you are screwing up the ASA engine with those statements, especially the 0.0.0.0 one.

Instead, use a single IP or multiple IP addresses in the server's DMZ(192.168.200.0) for Nat'n the internal clients. This way when you talk to the servers from the inside network you look local to the DMZ(IE 192.168.200.0 net)

try something more like this.

global (outside) 1 207.229.61.150

global (dmz) 1 192.168.200.200-192.168.200.253

global (dmz) 1 192.168.200.254

nat (inside) 1 192.168.1.0 255.255.255.0 0 0

this should cause anything going outside from the inside network to go to PNAT(port nat) on 207.229.61.150

the dmz traffic should get IP to IP maps for the first 53 or so connections then fall to PNAT on 192.168.200.254 for more then 54 connections.

Try those and see if it works.

Remember the ASA engine will automatically allow higher interface connections to lower, so there's no need to create extra rules for that(IE the No-nat statements) If still have access issues, then it's time to look at the ACL's(access-control lists). You should only really need them for the static maps from the outside to the dmz, the rest should be handled automatically.

-K

New Member

Re: Could something be wrong with my pix? Please help!!

Hi,

Thanks for the response! The nonat statement is there for the VPN traffic. 192.168.200.0 is the VPN pool.

New Member

Re: Could something be wrong with my pix? Please help!!

I figured it was something like that.

drop the 0.0.0.0 nat statement and try being more specific with the rules.

I would also on the temp, not apply the ACL's for VPN til u have a working setup, then try them. So you know which rules are breaking things and which are not.

-k

New Member

Re: Could something be wrong with my pix? Please help!!

Hi,

For testing Purpose make simpler Static commands:static (inside,outside) 207.229.61.2 192.168.100.138 .

Hope it will work.

Thanks

Vijay

New Member

Re: Could something be wrong with my pix? Please help!!

regarding citrix servers, in my opinion you need to add 2 entries in inbound al:

access-list inbound permit udp any host 207.229.61.4 eq 1604

access-list inbound permit udp any host 207.229.61.5 eq 1604

Regards, Archi

New Member

Re: Could something be wrong with my pix? Please help!!

I'm wonder if on my access-list instead of permitting the address through to the external static address, if I permit it to the internal address.. hmm .. let me try that today when I get a chance.

thanks everyone for your help so far.

151
Views
0
Helpful
8
Replies