Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CS-MARS database corruption

I am having a "fun" issues with our CS-MARS box. The browser is generating errors when attempting to log in to the web GUI (and there are only the 2 fields in the upper left corner now, the whole login screen changed). It is giving me a "object required" error, and pointing to the index.jsp page of the box.

I called TAC and sent them logs, they said that the database is corrupted and the only way to fix it is to reimage the whole box.

My question is this: Is there ANY way to get the rule's, devices, configuration out of this box before I reimage it? We paid a consultant 2 weeks of work to configure this box, and to just trash it without any sort of error recovery seems like a giant waste of money and time. I know how to configure it, but it's going to take a seriously long time to get it back up and working again.

Any help would be appreciated.

2 REPLIES
New Member

Re: CS-MARS database corruption

New Member

Re: CS-MARS database corruption

Hi,

I guess you've upgrade the box to 4.2.1. I have the same error. There's a bug in that release concerning to a log file that blocks the Oracle database. The Field Notice for that error is FN-62505. You'll find a patch there but if you try to do a "pnstatus" by SSH you'll get an error message like: "Program aborted due to: ORA-12541: TNS:no listener" If you have this kind of message, contact with Cisco TAC because they'll need to play into the device. At this moment my device is down due to this failure. It still responses to its management IP by ssh but I can't anything by the GUI. It returns the same error than your.

Concerning to the backup, there's a procedure in the installation manual. I haven't test it but I've seen you have to create an NFS connection against the device.

Good luck!

99
Views
5
Helpful
2
Replies