Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CS-MARS device discovery

I'm trying to discover equipment, primarily routers, for the CS-MARS 100e. I'm trying to use telnet to connect to the routers, but It receives an error. The error shows it connects and sees the login banner, but it will not discover it. Any ideas? Or, is there a better way?

I may just have to turn on SNMP to all of the routers, but I'm told that will not give me the same information.

4 REPLIES
Silver

Re: CS-MARS device discovery

Did you configure a username and password on the MARS box for the routers you are trying to discover?

This is how I was taught and how it has worked for me

in the field:

You must configure SNMP community strings in order for the MARS box to discover the routers you want to manage. Additionally, point the routers syslog output at the MARS box. Lastly, you must modify your network to allow SNMP through any firewalls or ACLs you have in place.

Hope this helps.

New Member

Re: CS-MARS device discovery

I have tried using the username and password and still received the error.

SNMP has worked on the other routers, etc., so I'll just set that up on these routers as well.

New Member

Re: CS-MARS device discovery

Two things you might look at/try. First your router has to be set up for telnet. Make sure you don't have an access-list blocking what address can use telent...which is a good idea to use btw. If you are using one add the address of CS-MARS.

Secondly get into the command line of CS-MARS and try to telnet to the router. It is a lot easier to troubleshoot the issue that way. Good luck.

New Member

Re: CS-MARS device discovery

Remove the banner, then discover the device via telnet. Then re-add the banner.

DC

119
Views
4
Helpful
4
Replies
CreatePlease login to create content