Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CSA 4.5 hosts detach from groups

I am using CSA 4.5.1.639 and am seeing hosts (desktops and servers) that detach themselves from all groups. Even though they were installed and registered with the MC months ago, they say they have a recent registration time. All of the agent kits for these hosts are still listed in the MC. They also show the following event:

"No security policies are being enforced on this agent. This could be due to an incompatible software version (the agent is running version 4.5.1.639) or the agent has re-registered and the original installation kit has been removed. This agent should be added into the correct group(s) and the rules regenerated as soon as possible. If the agent software is not current, then it should be updated."

Does anyone have any ideas?

11 REPLIES
New Member

Re: CSA 4.5 hosts detach from groups

Mabe the machines are reimaged

I have not seen this message before.

Blue

Re: CSA 4.5 hosts detach from groups

I've seen where an agent kit is reinstalled and it has no group associated with it.

I've also seen this from machines that were deleted from the MC and the original group it attached to is no longer there.

Do you have a forced install for your PCs?

Tom S

New Member

Re: CSA 4.5 hosts detach from groups

We push a silent install via our software deployment application, if that's what you're asking. Sometimes this occurs and there are multiple hosts listed in the MC with the machine name in question and sometimes there is only a single instance of the host in the MC.

However, we have not deleted any groups.

Blue

Re: CSA 4.5 hosts detach from groups

A silent install should not install again on a host unless it is a newer version. Are you saying that this occurs and you get duplicate hosts?

If so, that may be related to your problem. Some hosts may register again and others may just get knocked off (yeah, that's a technical term..).

Is this a standard software deployment app like SMS or ZenWorks?

We use Zenworks but it doesn't try to install unless there is no okclient.exe present. Even if it does, it says "client is already up to date" or something like that.

Tom S

New Member

Re: CSA 4.5 hosts detach from groups

We use a standard software deployment app. The app keeps track of which apps it has pushed by marking a flag for that package. So will not get installed again unless the flag was manually removed, even if we updated the agent kit install executable.

I believe we see duplicate hosts because the machines were reimaged (with the same hostname) and then CSA was installed.

New Member

Re: CSA 4.5 hosts detach from groups

Hi Brian,

if you see duplicate hosts in host list I`ll recommend that you delete both entries and let the agents (re)register themselves. This could happen under particular circumstances.

Regards,

Arne

Blue

Re: CSA 4.5 hosts detach from groups

Brian, did the agent kits that installed these hosts belong to any groups? If not, try creating another kit that belongs to the group(s) you want these hosts to be in and install it on a couple of problem hosts.

Does it happen often or infrequently? I am running in to a situation where some hosts will revert to the original group they belonged to with a new registration date and I haven't deleted them.

Tom S

New Member

Re: CSA 4.5 hosts detach from groups

Tom, the agent kits used to install these hosts were attached to a number of groups. It seems to happen once every week or two. We'll just notice a few machines sitting in the MC not associated with any groups. We have since setup an e-mail alert about this, but we'd still like to find the root cause and fix it.

New Member

Re: CSA 4.5 hosts detach from groups

So more information has come to light. The machines that are experiencing this issue have all are being installed with agent kits that are no longer in the MC. We have searched the audit trail but there is no record of them ever being deleted.

Has anyone else noticed agent kits disappearring from the MC in v4.5.1.639?

Blue

Re: CSA 4.5 hosts detach from groups

No, but if the groups that the kits were associaed with were deleted this could occur. See if any groups were deleted (and recreated with the same name maybe?).

Tom S

New Member

Re: CSA 4.5 hosts detach from groups

Thanks for your help, Tom.

It is possible that some of the groups have been renamed, but they haven't been deleted.

-Brian

135
Views
0
Helpful
11
Replies
CreatePlease to create content