Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CSA Agent 5.2 to 6.0 upgrade not working

It appears that if the following sequence occurs, then it is not possible to upgrade a 5.2 Agent to 6.0

1. Client starts with Win XP SP2

2. CSA Agent 5.2 is installed

3. Client is upgraded to Win XP SP3

4. MC is upgraded to 6.0. At this point, when the client is added to the upgrade group, it never gets upgraded.

Has anyone else encountered this problem?

7 REPLIES
Blue

Re: CSA Agent 5.2 to 6.0 upgrade not working

XP SP3 is not supported on CSA 5.2.

Deploy CSA 6 first, then SP3.

Tom

New Member

Re: CSA Agent 5.2 to 6.0 upgrade not working

Thanks for the information. That's the exact indication that I've seen. Do you have any Cisco references to that limitation?

Blue

Re: CSA Agent 5.2 to 6.0 upgrade not working

Yes, the install guides for both versions list supported OSs.

5.2 supports XP SP2 and 6 supports XP SP3.

The summary page for a 5.2 MC lists XP SP3 hosts as 'Hosts with unsupported platform'.

Tom

New Member

Re: CSA Agent 5.2 to 6.0 upgrade not working

I successfully tested an update from CSA 5.2 to a higher 5.2 Version on a XP Client with SP3 installed even if the client is marked as an "unsupported Plattform." in Management Center.

Therefor you must schedule the update to a group which ist assigned to your Agent Kit which is initially installed on the client. Delete the host you want to update in the CSA MC. Next time the Client registers at the Server, it gets the update scheduled to the initial group.

I think this will work for an Update from 5.2 to 6.x too.

Our Problem is an update from 4.5 to 5.x respectivly 6.x. This workaround don't work with CSA 4.5 Clients.

Are there any ideas for further testing an update from 4.5 to a higher Version?

New Member

Re: CSA Agent 5.2 to 6.0 upgrade not working

Could you just go through this, i'm a bit slow today.

You mention that you schedule an update to a group not assigned to the initial agent kit, then say it gets the update scheduled to the initial agent group. I'm not uderstanding this to well.

It will sure save me a lot of time.

Ta

New Member

Re: CSA Agent 5.2 to 6.0 upgrade not working

The Group to use for scheduling the update has been assigned to the initial Agent Kit when it was generated.

Our initial Agent Kits have Groups associated with them. It is possible to schedule an update to one of these groups.

Michael

New Member

Re: CSA Agent 5.2 to 6.0 upgrade not working

I have updated the hosts, but I have to trick the system by editing the database "software_update_os" and add an entry for "0005.0001.0003.2600" so it would update SP3.

225
Views
0
Helpful
7
Replies