Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CSA agents could not registered with CSAMC

Hi all,

I have just rebuild my CSAMC and install 4.5.1.565 (VMS2.2), since installation, my csa agent Pcs could not registered with csamc, all agents in Test Mode group. I have valid licenses for csamc, agent, vms & servers.

Any thought Please?

ade

mgn

6 REPLIES
New Member

Re: CSA agents could not registered with CSAMC

From my understanding, you have rebuilt the CSAMC but the agents were reporting to the old one? Or you have created new Agentkit and distributed to the machines?

-I am assuming the CSAMC resides in the same server. Every thing is the same (active directory name)

-You are not updating software to 4.5.1.565 from older versions.

If so you need to Scheduled Software Updates, but even so, I guess the agents need to be reporting to get the update!

-Make sure you have in

Registration Control

Enter the IP address ranges allowed to register with the Management Console:

I doubt that this is the case

New Member

Re: CSA agents could not registered with CSAMC

I Have only 1 CSAMC server, I have deployed the agent kit in TestMode, assign policies to the Test-group and I have even upgrade to 4.5.1.639 none of the agents could still registered with CSAMC.

Thanks for your input will try your suggestion.

ade

Blue

Re: CSA agents could not registered with CSAMC

My understanding is if they were reporting to the old MC, they won't report to the new one because the certificate is different.

Tom S

New Member

Re: CSA agents could not registered with CSAMC

Yep, excactly. Tom is right. You`ll have to manually refresh certificates on installed agent hosts or uninstall old agents and roll out new kits(would prefer this one). agent kits contain csamc server ssl certificate which in this case is old(unknown) one. remember that agents communicate via ssl handshake with management center.

Otherwise check if domain name lookup (forward and reverse) could be correctly answered. But seems to be that Tom was already on right track.

Regards,

Arne

New Member

Re: CSA agents could not registered with CSAMC

Ade,

You just have to make sure that you back up the CSAMC server and store the files some where. When you build the new MC, move back the back-up files and run ?restore configuration? utility on the server.

Agents from the old MC will be able to communicate with the new MC. I have tried this several times in our disaster recovery drills.

Check the attached file.

New Member

Re: CSA agents could not registered with CSAMC

Make sure you can ping the MC and have the address in the host-file.

Also the MC uses PKI encrptytion bound to the IP address of the MC so; You need the same MC IP address. create new agent kits and re-try.

P.S. Make sure Firewalls have the proper ports open.

123
Views
15
Helpful
6
Replies
CreatePlease to create content