Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CSA and okclient.exe error during logons

Hi,

I am getting this error everytime we login to a W2K3 R2 SP2 system. I have tried the following:

-Uninstall and re-install the CSA client

-Checked Windows Services for the CSA service logon properties and it is set to local system account

-Disbaled CSA from the startup menu, rebooted. The error message did not appear at startup.

The CSA service (CSAControl.exe) starts Automatically at boot up without the okclient.exe running at startup. however

When I launch the okclient manaually after a reboot, the error returns. (The application failed to initialize properly (0XC06d004e).

Does anyone have any ideas on how to fix this?

Thanks

3 REPLIES
Blue

Re: CSA and okclient.exe error during logons

Need more information to make a guess.

Did it ever work?

Do you have a policy preventing the Agent UI?

Any event log errors?

Is it 64 bit Windows?

Do you have similar servers where it does work?

CSA version?

Log on as a different user?

Information from the CSAgent-Install.log and driver_install.log may be useful.

Tom

New Member

Re: CSA and okclient.exe error during logons

Hi sorry here is some more info:

-Its never worked as it is a new Installation of CSA version

-Its 32 Bit Windows

-CSA version is 5.1.0

-Error happens no matter what user logs into the system. CSA flag does not run in system tray either.

I do see the following that is suspicous

[2009-08-11 08:01:16.640] [PID=888] [Csamanager]: Failed to initialize Windows Firewall, error: 0x800706d9

[2009-08-11 08:01:16.640] [PID=888] [Csamanager]: Failed to update Windows Firewall status after 80 seconds, error: 0x800706d9 - The method failed because the Windows Firewall, Internet Sharing Service (SharedAccess) was not running.

[2009-08-11 08:01:18.625] [PID=888] [Csamanager]: Failed to update CSA registration with Windows Security Center after 80 seconds (5 attempts), error: 0x8004100e - Namespace specified could not be found. Possible cause: SecurityCenter interface is not registered with the system; WMI repository may need to be rebuild.

I have attached some of the log files.

Blue

Re: CSA and okclient.exe error during logons

It looks like you don't have a rule allowing the agent UI to run on that host.

[2009-08-11 08:01:00.109] [PID=4264] [AgentUI]: AgentUI starting... [secure]

[2009-08-11 08:01:00.156] [PID=4264] [AgentUI]: Agent UI is not allowed to run. Will exit.

[2009-08-11 08:01:00.156] [PID=4264] [AgentUI]: AgentUI exiting

If you don't have one allowing it, it won't be able to run.

Tom

543
Views
0
Helpful
3
Replies