Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CSA - failed to compile the configuration (import related)

Hi,

I'm importing policies to a new 5.2 server from an older 4.5.1 server. When I attach these policies to a group and use them, I get this error:

The agent software failed to compile the configuration sent from the central server:

Iteration: 0

-- (000) 0010 00 00 00000000 .... ld #0

-- (001) 00a0 00 00 00000201 .... st M513

-- (002) 00a0 00 00 00000001 .... st M1

-- (003) 0010 00 00 00000000 .... ld #0

-- (004) 00a0 00 00 00000301 .... st M769

-- (005) 00a0 00 00 00000002 .... st M2

-- (006) 0010 00 00 00000000 .... ld #0

-- (007) 00a0 00 00 00000401 .... st M1025

-- (008) 00a0 00 00 00000003 .... st M3

-- (009) 0010 00 00 00000000 .... ld #0

-- (010) 00a0 00 00 00000501 .... st M1281

-- (011) 00a0 00 00 00000004 .... st M4

-- (012) 8c90 00 00 00944d48 RO.. ld M[']

-- (013) 28a0 00 00 00000602 .OA. st M1538

-- (014) 0c90 00 00 00000602 RO.. ld M1538

-- (015) 28a0 00 00 00000005 .OA. st M5

-- (016) 8c90 00 00 00944d48 RO.. ld M[']

-- (017) 28a0 00 00 00000702 .OA. st M1794

-- (018) 0c90 00 00 00000702 RO.. ld M1794

-- (019) 28a

I've tried exporting/importing different policies, different individual modules, etc. and this happens every time. Do I have to rewrite all these rules from scratch?

1 REPLY
New Member

Re: CSA - failed to compile the configuration (import related)

Well I figured out what is causing this. I attached a single module to a policy, generated, polled, wait for the error - I narrowed it down to one module that contained API rules. They were looking for specific patterns in memory. I wonder if the pattern format changed from 4.5.1 to 5.2, and this compilation error is because of incompatible syntax.

Is anyone familiar with the API pattern syntax?

95
Views
0
Helpful
1
Replies