Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CSA instability and other issues

I have an issue in a Citrix environment (Windows 2003 SP1 standard, Citrix Presentation Server 4, CSA 5.0.0.194, dual CPU with hyperthreading on, 4 gig ram) where if I have CSA installed on a server and I run our custom application, the application does not properly load-balance across all CPU's. Likewise, when CSA is running, the server(s) in question eventually become unresponsive and they have to be hard rebooted; this is characterized by the console of the server in question going blank (gray screen), the login screen never appearing again. To get the server back, you have to do a hard reboot...either pull the plug, or you can do a CTRL-SCL-SCL if you have Windows configured to respond to that. There is no other way to get the server back.

If you do not have CSA installed, none of this ever happens. However, even if the CSA service is stopped, or if it's started but running in TESTMODE, the same thing happens, it just takes longer.

Has anyone ever seen this behavior before? We've even gone so far as to completely blow away (reformat) a server, the reload only Windows, Citrix, and the CSA, and the application in question still only runs on one CPU, and the server becomes unstable. As soon as the CSA is uninstalled (not stopped, but COMPLETELY uninstalled), everything works fine again.

Has anyone seen anything even remotely close to this behaviour? We have been researching this issue going on a year, and we have narrowed it down to the CSA. I already have a ticket opened (we have software support), but at this point, CSA is unusable, because it's the culprit...directly or indirectly. I'd like to know if anyone else has seen this, and if so, is there any workaround.

2 REPLIES
Blue

Re: CSA instability and other issues

I saw something similar a while back with our Trend Micro AV server and CSA 4.X.

CSA still has to process rules, even in test mode. Have you tried putting it in a group with no policies at all?

I'm assuming you aren't getting any events to provide clues.

New Member

Re: CSA instability and other issues

Yes. We tried it last night. Doesn't make a difference. When CSA exists on the server (whether rules are applied to it or not, whether it's actually running or not), the application in question will only use the first cpu (CPU0). Likewise, under normal load, the server will eventually become completely unresponsive. Uninstall CSA, server is fine indefinitely.

92
Views
0
Helpful
2
Replies