Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

CSA Register issue

I am just deployed a Version 5 Test server and im trying to register a machine with this server. But I am unable to register this machine and receive an error of 'Fast Poll unsuccessful. Check agent file' which I have and I am getting this

2006-08-22 18:07:51.337] [PID=1048] [Csamanager]: conn_check: https : mgmtserver is reachable via https

[2006-08-22 18:07:51.337] [PID=1048] [Csamanager]: conn_check: finished

[2006-08-22 18:07:51.337] [PID=2876] [AgentUI]: Failed to send event with code 648

[2006-08-22 18:08:20.401] [PID=1048] [Csamanager]: Performing fast poll...

[2006-08-22 18:08:20.401] [PID=1048] [Csamanager]: inquire_config_status: exit: Agent is not registered.

[2006-08-22 18:08:20.432] [PID=1048] [Csamanager]: Registration failed without message Error code=2035

[2006-08-22 18:08:20.432] [PID=1048] [Csamanager]: Registering with server keycsadev.keymed.local, Failure (2035)

[2006-08-22 18:08:20.432] [PID=1048] [Csamanager]: inquire_config_status: exit: Agent is not registered.

[2006-08-22 18:08:20.510] [PID=1048] [Csamanager]: Registration failed without message Error code=2035

[2006-08-22 18:08:20.510] [PID=1048] [Csamanager]: Registering with server keycsadev.keymed.local, Failure (2035)

[2006-08-22 18:08:20.510] [PID=1048] [Csamanager]: inquire_config_status: exit: Agent is not registered.

[2006-08-22 18:08:20.573] [PID=1048] [Csamanager]: Registration failed without message Error code=2035

[2006-08-22 18:08:20.573] [PID=1048] [Csamanager]: Registering with server keycsadev.keymed.local, Failure (2035)

[2006-08-22 18:08:20.573] [PID=1048] [Csamanager]: Performing fast poll...Failure (2035).

[2006-08-22 18:08:20.573] [PID=1048] [Csamanager]: conn_check: started

[2006-08-22 18:08:20.619] [PID=1048] [Csamanager]: conn_check: ip config: ok. one local address is 10.56.57.6

[2006-08-22 18:08:20.619] [PID=1048] [Csamanager]: conn_check: dns : resolved mgmtserver name keycsadev.keymed.local to 10.56.4.201

[2006-08-22 18:08:20.619] [PID=1048] [Csamanager]: conn_check: https : mgmtserver is reachable via https

[2006-08-22 18:08:20.619] [PID=1048] [Csamanager]: conn_check: finished

[2006-08-22 18:08:20.619] [PID=2876] [AgentUI]: Failed to send event with code 648

Any help would be great

6 REPLIES
Silver

Re: CSA Register issue

You are getting this message because you have run out of licenses... Here is a list of the CSA error messages... Please rate if this is useful. Thanks.

OKENA_STATUS_INVALID_SYSTEM_CONFIGURATION = 2000,

OKENA_STATUS_ICC_FAILED_GET_HANDLE = 2001,

OKENA_STATUS_ICC_FAILED_TO_WRITE = 2002,

OKENA_STATUS_ICC_FAILED_TO_READ = 2003,

OKENA_STATUS_ICC_INVALID_TOPOLOGY = 2004,

OKENA_STATUS_ICC_INVALID_INITIATOR_COMP = 2005,

OKENA_STATUS_ICC_INVALID_PAYLOAD_SIZE = 2006,

OKENA_STATUS_ICC_INVALID_VERSION = 2007,

OKENA_STATUS_ICC_INVALID_COMP_ID = 2008,

OKENA_STATUS_ICC_INVALID_PAYLOAD = 2009,

OKENA_STATUS_GROUP_DOES_NOT_EXIST = 2010,

OKENA_STATUS_INVALID_REGISTRATION_PARAMS = 2011,

OKENA_STATUS_HOST_HAS_REGISTERED_BEFORE = 2012,

OKENA_STATUS_INVALID_CONTACT_INFO = 2013,

OKENA_STATUS_HOST_NOT_REGISTERED = 2014,

OKENA_STATUS_MISSING_CONTACT_INFO_PARAMS = 2015,

OKENA_STATUS_INVALID_REGISTRATION_ID = 2016,

OKENA_STATUS_ICC_INVALID_BYTE_ORDER = 2017,

OKENA_STATUS_ICC_NOT_INITIALIZED = 2018,

OKENA_STATUS_COMP_CONFIGURED = 2019,

OKENA_STATUS_UNDEFINED_MGMT_SERVER = 2020,

OKENA_STATUS_HTTP_TRANSACTION_FAILED = 2021,

OKENA_STATUS_ICC_INVALID_HANDLE = 2022,

OKENA_STATUS_SERVER_IS_REACHABLE = 2023,

OKENA_STATUS_HTTP_TIMEOUT = 2024,

OKENA_STATUS_ICC_NO_CONNECT_MUTEX = 2025,

OKENA_STATUS_FORCE_POLLING_NOW = 2026,

OKENA_STATUS_REGISTRATION_REJECTED = 2027,

OKENA_STATUS_LOAD_CONFIG = 2028,

OKENA_STATUS_DB_ERROR = 2029,

OKENA_STATUS_LICENSE_REACHED_LIMIT = 2030,

OKENA_STATUS_REGISTRATION_NOT_ALLOWED = 2031,

OKENA_STATUS_NOT_ALLOWED_TO_STOP_AGENT = 2032,

OKENA_STATUS_CLIENT_UI_NOT_ALLOWED = 2033,

OKENA_STATUS_FAILED_TO_PRINT_AGENT_REPLY = 2034,

OKENA_STATUS_INVALID_LICENSE = 2035,

OKENA_STATUS_TIMED_OUT = 2036,

OKENA_STATUS_REGISTRATION_BACKOFF = 2037,

OKENA_STATUS_TESTMODE_ON = 2038,

OKENA_STATUS_TESTMODE_OFF = 2039,

OKENA_STATUS_INVALID_SERVER_FQDNS = 2040, OKENA_STATUS_INVALID_SERVER_IPADDR = 2041, OKENA_STATUS_SERVER_DNS_NOT_RESOLVABLE = 2042, OKENA_STATUS_SERVER_IPADDR_NOT_OWN = 2043, OKENA_STATUS_SERVER_DNS_NOT_OWN = 2044, OKENA_STATUS_SERVER_NAME_NOT_FQDNS = 2045, OKENA_STATUS_FAILED_OPEN_PROCESS = 2046,

Silver

Re: CSA Register issue

Sorry I meant your license is invalid on that agent. You need to check with licensing@cisco.com to get the issue resolved. Thanks.

Community Member

Re: CSA Register issue

I'm also getting this registration error periodically, and it has nothing to do with a valid license. The log file snippet below shows that after the agent failed to register, it was able to poll successfully and register an hour later at the subsequent polling interval. (BTW it also failed on several attempts to fast poll manually.) This is happening sporadically in my network, but today I saw the same symptoms on 4 PCs at the same time. I have a TAC case open on this but no solution yet.

[2006-09-13 12:53:54.509] [PID=3524] [Csamanager]: MC Reachability state has been set to 'Reachable'.

[2006-09-13 12:53:54.509] [PID=3524] [Csamanager]: Registration failed without message Error code=2037

[2006-09-13 12:53:54.509] [PID=3524] [Csamanager]: Registering with server NTNIPH1347M00.ho.nmfco.com, Failure (2037)

[2006-09-13 12:53:54.509] [PID=3524] [Csamanager]: Will retry to register in 3600 sec

[2006-09-13 13:53:59.813] [PID=3524] [Csamanager]: Registering with server NTNIPH1347M00.ho.nmfco.com, Success (0)

Community Member

Re: CSA Register issue

Per jwalker's error code list, 2037 is REGISTRATION_BACKOFF. Even though the server was accessible on the network at the time, could the DB have been overloaded? How many installs are you doing at one time?

Community Member

Re: CSA Register issue

There are only about 100 agents polling this server. The poll interval is 1 hour. I'm wondering if there might be some database fragmentation or something going on. I see that for about 40 of the agents, there are two host entries. One is listed as Inactive while the other is Active. All other information on the host is the same (except for time since last poll). I have a TAC case open to try to find out what causes this duplicate host situation. In the meantime I'm going to manually delete all of the inactive hosts via the MC.

Community Member

Re: CSA Register issue

You can get duplicates if the agent is reinstalled on the same machine. It changes the agent's UID, and the MC treats it as a new host.

How did you deploy the agents? Did you put an installation routine in the login scripts? Did you go to each machine one by one? Did you send an email to your users with instructions? Maybe you used an Active Directory policy? Do you have a Scheduled Software Update in the MC configured?

How large is your DB right now? Did you go with MSDE, a local MS SQL db, or a remote MS SQL server?

307
Views
9
Helpful
6
Replies
CreatePlease to create content