Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CSPM 2.3.3i database corruption

Hello,

I seem to have database corruption. I've tried login in to CSPM and it will reject the login with an error message stating that the database can not be initialized. What would be the best way to try to repair the database without having to lose the configuration?

Thank you!

1 REPLY
Cisco Employee

Re: CSPM 2.3.3i database corruption

Navigate to the CSPm directory and save your current configuration off to a .cpm file somewhere NOT under the CSPM

directory structure (sorry, can't remember the exact directory, but every time you save your configuration there's a .cpm file created which is your config file, find the directory with all of these in it and save the last few of them off into another directory).

Now go to Start - Programs - Cisco Systems - CSPM - Troubleshooting Toolkit, under

the Restore Policy Database tab hit the Restore button and wait for the 4 checkboxes to check themselves off. Now open up

CSPM again and it'll come up with a blank database. Go to File - Import and import the .cpm file you just exported back in. Remove the new "Imported" user from the bottom menu on the left hand side, and do a Save/Update and that should be good.

If it still doesn't work you may need to import one of the older database (.cpm) files in.

95
Views
0
Helpful
1
Replies