Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CSPM Server Crash

I am having a problem with CSPM. The WinNT 4.0 server that it is running on locked up and had to be power cycled. This could possibly have been because the alarm database had gotten too large but this has never been a problem in the past. The machine and WinNT 4.0 came back up without any errors. However when I opened the CSPM application I got a Cisco Secure Policy Manager error window. It read "Failed to initialize tree node "" of type "I" probably due to inconsistency between current database contents and the revision level of this application.

I press OK to continue. The topology loaded and looked fine except for a few alarm templates that I had created.

I tried to do a "cvtnrlog -d" to erase the alarm database but all I kept getting was Dr. Watson errors.

Then I used the CSPM Troubleshooting toolkit to reset the topology database. After the topology was reset I imported a backup copy of the topology that I have saved in a backup folder. After this was done I did another update of the current alarm signature file. Did a save, update and then rebooted the server.

Then I tried to quiery a few sensors but it came back with an error. If I try to "poll" a sensor from the Command tab it comes back as "No status specifeid". Also on the Command tab the "Approve Now" button stays grayed out even after changes are made and I do a Save and Update.

If I go to any of the sensors an nrconns shows "Established" and a snoop -d shows 2 way communication on port 45000. A nrstatus shows all of the services are running, including nr.postofficed.

Everything looks like it should be working, but the CSPM server will no longer update, poll, or quiery any of the sensors. I also tried deleting a sensor and adding it back to the topology. This did not help.

Does anyone have any suggestions or know of anything I could look at to get this beast working again.

3 REPLIES
Cisco Employee

Re: CSPM Server Crash

In situations like this, where the CSPM database is corrupted, first option was to reset using the troubleshooting toolkit, which i see did not help. I would suggest you to uninstall CSPM, reboot, and do a fresh install and then import your cpm file. Hope that helps.

R/Yusuf

New Member

Re: CSPM Server Crash

Thanks for your reply. I was hoping to avoid a reinstall of CSPM if at all possible. This would be the last resort, before water torture or high voltage therapy.

New Member

Re: CSPM Server Crash

Actually the reinstillation is pretty easy. I have done it ummm, maybe 30 times on our systems.

I have found the CSPMi database to be highly unstable. The reinstall always seems to resolve my issues though.

We actually tossed CSPMi in favor of using the web config tool, now that we are getting Cat6000 blades we'll need to go back.

*sigh*

Just waiting till something better comes along.

107
Views
0
Helpful
3
Replies