Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CTA certificate installation problem

Hi,

since 2 weeks i get an error when i try to install the certificate of my ACS on the client.

i tried the automate install within the cta. also tried the manual install with ctacert. Both methods end with an error.

There no entries in the log. Also no entries in the event viewer.

I really don't know what reason causes this error, never had any problems before.

Maybe someone of you have an idea.

regards

harry

4 REPLIES
New Member

Re: CTA certificate installation problem

For the most part, the ACS certificate needs to be in the local machine certificate store of the client station. Are you trying to install an ACS self-signed certificate? In the certificate, make sure that the "Issued by" and "Issued to" fields are the same to indicate a Root cert.

If you are using CTA 2.0, you can uninstall CTA, create a folder called "certs" in the same directory as the cta.exe installation file, add the ACS cert into that directory, and run the executable again.

Or after installation, you can use the ctacert.exe utility to add the cert:

C:\Program Files\Cisco Systems\CiscoTrustAgent> ctaCert.exe /ui 4 /add "c:\mycerts\acscert.cer" /store "Root"

On what operating system/service packs are you trying to install the cert? If this is a test environment, perhaps you can attach the cert you're trying to install.

New Member

Re: CTA certificate installation problem

i tried both methods to install the certificate. none works. i installed the same cta on the same laptop 2 weeks ago and it worked.

I reinstalled it now, because i had to assign a new certificate to my ACS Server. (not self-signed)

I also removed all "old" certificates from the client, even tried to uninstall cta before installation.

root certificate is installed.

New Member

Re: CTA certificate installation problem

What is the exact error that you are getting on that client station?

In the root certificate that you are trying to install on the client station, is the "Issued to" and "Issued by" fields the same?

Is it just the one machine that you're having this issue? What Windows OS/Service Packs and privileges do you have on this machine?

Sincerely,

Annie

New Member

Re: CTA certificate installation problem

it works now,

the problem seems to be the Domain Admin,

only can install it with the local Admin.

195
Views
0
Helpful
4
Replies
CreatePlease login to create content