Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CW2K Java Errors - Custom Reports

This one has the company field engineers that take care of the PCs bedazzled. They cannot figure it out and have tried a myriad of approaches to try and resolve this issue. Thus I am approaching it from a different direction now. Below are versions of what I have running on my system and what we have done to try and resolve this trouble.

Trouble:

When opening "Custom Reports" under any folder where it is available a java error occurs. This error stops the loading of the Custom Reports Module.

error: java.lang.NoSuchMethodError: COM/jscape/widgets/Label3d: method <init>Ljava/lang/String;Iljava/awt/color;Iljava/awt/Fon

Versions:

Windows2K OS SP2

IE: Version: 5.504807.2300CO

Update Versions:;SP2;

Java(TM) Plug-in: Version 1.3.1

Using JRE version 1.3.1 Java HotSpot(TM) Client VM

C:\WINNT\system32>java -showversion

java version "1.3.1"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1-b24)

Java HotSpot(TM) Client VM (build 1.3.1-b24, mixed mode)

C:\WINNT\system32>jview

Microsoft (R) Command-line Loader for Java Version 5.00.3805

Copyright (C) Microsoft Corp 1996-2000. All rights reserved.

wjview Version:5.0.3805.0

Attempts:

Updated SP1 to SP2

Updated Windows Virtual Machine using "msjavax86"

Updated all security patches

Reinstalled IE (Java and Java console are enabled)

Applied Hotpatch Q300845_W2K_SP3_X86_EN

The only thing I have not tried yet is to download and load Java 1.4 from http://java.sun.com

The basic error is on the Java Sun site but it does not go into any detail as to how to correct this error.

If there is anything you can point me towards that will allow me to use the "Custom Report" feature for CiscoWorks2K it would be appreciated.

Kim

1 REPLY
Blue

Re: CW2K Java Errors - Custom Reports

RME 3.3 does not support Java Plug-in 1.4, only 1.3.1 is suported. Try doing a CCO Bug Toolkit search to see if you're hitting any known bugs.

91
Views
0
Helpful
1
Replies
CreatePlease to create content