Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Device Manager fails upon login

Upon submitting user and pass when logging into IDS Device Manager browser displays "An error has occurred". The only option is to click OK, at which point the entire background of the page (Cisco logo, function buttons, etc) comes up, but none of the Java portions come up. If I click anything on the page, I'm again prompted for user/pass, and the process begins again.

This occurs on Netcape and IE, all versions, and on more than one client. I have searched the forums, and have done all the remedial checks like checking sysconfig and so on. It had been working for roughly two months prior to this. Any ideas aside from re-imaging the sensor?

Any help would be greatly appreciated.

4 REPLIES
Community Member

Re: Device Manager fails upon login

I haven't heard or seen this issue before, and there are limited details in your posting on the issue. I would suggest that you may want to take a look in the documentation at the section on 'Validating the certificate fingerprint'. This should be the link:

http://www.cisco.com/univercd/cc/td/doc/product/iaabu/csids/csids8/13872_01.htm#xtocid9

If you continue to have this issue, I would suggest that you open a TAC case, so that we can help you troubleshoot this issue further.

Thanks.

Chris

Community Member

Re: Device Manager fails upon login

Thanks for the reply Chris,

Unfortunately validating and importing the certificate was one of the first things I tried when things went south. I tweaked the browser settings to low security, accepting all cookies, validated the certificate, and put the sensors in the Trusted Sites zone. the truly weird thing is that I have two separate sensors and they're both doing it.

I have in fact opened a TAC case, thanks again for your help.

Cisco Employee

Re: Device Manager fails upon login

Try logging into the Sensor as the netrangr user and go to the /usr/nr/etc/ directory. Edit the destinations file and verify that each destination has at least one data type. Example:

1 IDM.cisco loggerd 1 EVENTS,ERRORS,COMMANDS,IPLOGS

There is a bug that occurs if a destination does not have a data type defined. In this case, IDM will not be able to initialize.

An alternative is to log in as root and run sysconfig-sensor, option 6.

Community Member

Re: Device Manager fails upon login

Thanks for the reply Klee,

I checked the destinations file and each destination did have at least one data type; but the alternative WORKED! Running option 6 and keeping all my pre-existing info flushed it back out.

This (seemingly) all started when I tried to use the IDM to update the signatures. Ever try that? After you click "update now" the IDM dies and never comes back until you close the browser, and open it back up. I'm guessing that re-running option 6 must restart the services that get killed during that proc.

THANKS KLEE

87
Views
0
Helpful
4
Replies
CreatePlease to create content