Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DMVPN as backup link

Hi,

Trying to configure DMVPN as redundant link, A hub with four SPOKE,Wireless is the primary link and DMVPN is configured over ADSL link for redundancy,such that when the primary wireless link goes down EIGRP should select the alternate link and data traffic should flow through ADSL/VPN GRE tunnel

The issue is when the wirelss link is teared down, the SPOKE route goes down and can't reach the SPOKE, ADSL is a P2P interface with /30 IP address,

Any advice on this issue would be appreciated

Have attached config of HUB and one spoke router

3 REPLIES

Re: DMVPN as backup link

i cant see ant tunnel interface config on the SPOKE!!!!!

u need somthing liek:

crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

crypto isakmp key VPN address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

mode transport

!

crypto ipsec profile SDM_Profile1

set transform-set ESP-3DES-SHA

interface Tunnel0

ip address 192.168.220.1 255.255.255.0

ip nhrp authentication DMVPN_NW

ip nhrp map 192.168.220.1 10.8.253.98

ip nhrp map multicast 10.8.253.98

ip nhrp network-id 100000

ip nhrp nhs 192.168.220.1

tunnel source BVI1

tunnel mode gre multipoint

tunnel key 100000

tunnel protection ipsec profile SDM_Profile1

router eigrp 100

redistribute static

network 10.8.253.0 0.0.0.255

network 144.123.0.0

network 192.168.0.0 0.0.255.255

on the HUB add the following to the tunnel interface:

interface Tunnel0

no ip next-hop-self eigrp 100

no ip split-horizon eigrp 100

good luck

if helpful Rate

New Member

Re: DMVPN as backup link

Thanks for your reply marwanshawi,

I missed the tunnel config while copy+paste, attached the complete config of hub & spoke, still no luck, i could not understand why the tunnel interface goes down when wireless link is dropped. though the tunnel source interface is BVI which is bridged to ATM0/0/0(DSL) interface

New Member

Re: DMVPN as backup link

Hi All,

I figured out the problem, it was related to routing.

Thank you

194
Views
0
Helpful
3
Replies