Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DMVPN NHRP porblem

I got 4 routers. One is the hub (shanghai) and the other three spokes are Shenzhen, Guangzhou and Beijing.

The guangzhou router is:

GUANRT01#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.3(16), RELEASE SOFTWARE (fc4)

Beijing and Shenzhen is SHENRT01#sh ver

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(8), RELEASE SOFTWARE (fc1).

The tunnel between spoke and hub is up and working well. The spoke to spoke tunnel between Beijing and Guangzhou, shenzhen is fine. But the Tunnel between Guangzhou and Shenzhen doesn't work.

The configuration of Shenzhen and Beijing is same about the tunnel and EIGRP.

I debug NHRP on Guangzhou and Shanghai. I found Guangzhou sends NHRP resolution request to Shanghai and Shanghai receiveds the request and sends NHRP resolution to Guangzhou. But Guangzhou can't receive the reply.

When ping from Beijing to Guangzhou 172.20.200.1

BEIJRT01#ping 172.20.200.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.20.200.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 64/64/64 ms

BEIJRT01#

GUANRT01#show ip nhrp

10.128.23.0/32 via 10.128.23.0, Tunnel128 created 14w1d, never expire

Type: static, Flags: authoritative used

NBMA address: 10.10.10.128

10.152.20.72/32 via 10.152.20.72, Tunnel152 created 14w1d, never expire

Type: static, Flags: authoritative used

NBMA address: 10.10.10.152

10.152.20.88/32 via 10.152.20.88, Tunnel152 created 00:02:51, expire 00:00:46

Type: dynamic, Flags: router

NBMA address: 10.10.20.90

10.200.1.39/32 via 10.200.1.39, Tunnel228 created 14w1d, never expire

Type: static, Flags: authoritative used

NBMA address: 10.10.10.200

But when ping from Shenzhen to Guangzhou 172.20.200.1

GUANRT01#show ip nhrp

10.128.23.0/32 via 10.128.23.0, Tunnel128 created 14w1d, never expire

Type: static, Flags: authoritative used

NBMA address: 10.10.10.128

10.152.20.72/32 via 10.152.20.72, Tunnel152 created 14w1d, never expire

Type: static, Flags: authoritative used

NBMA address: 10.10.10.152

10.152.20.108/32, Tunnel152 created 00:00:40, expire 00:02:24

Type: incomplete, Flags: negative

Cache hits: 2

10.200.1.39/32 via 10.200.1.39, Tunnel228 created 14w1d, never expire

Type: static, Flags: authoritative used

NBMA address: 10.10.10.200

Any help is appreaited.

3 REPLIES
New Member

Re: DMVPN NHRP porblem

Debug at Guangzhou

Jan 2 09:50:31.296: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel152 netid-out 152

Jan 2 09:50:31.296: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:31.296: NHRP: No node found.

Jan 2 09:50:31.300: NHRP: Sending packet to NHS 10.152.20.72 on Tunnel152

Jan 2 09:50:31.312: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:31.312: NHRP: No node found.

Jan 2 09:50:31.312: NHRP: Attempting to send packet via DEST 10.152.20.72

Jan 2 09:50:31.312: NHRP: Encapsulation succeeded. Tunnel IP addr 10.10.10.152

Jan 2 09:50:31.312: NHRP: Send Resolution Request via Tunnel152 vrf 0, packet size: 83

Jan 2 09:50:31.312: src: 10.152.20.200, dst: 10.152.20.72

Jan 2 09:50:31.316: NHRP: 83 bytes out Tunnel152

Jan 2 09:50:31.352: NHRP: Receive Resolution Reply via Tunnel152 vrf 0, packet size: 111

Jan 2 09:50:31.356: NHRP: netid_in = 0, to_us = 1

Jan 2 09:50:31.356: NHRP: Checking for delayed event 10.10.21.110/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:31.356: NHRP: No node found.

Jan 2 09:50:31.356: NHRP: Delaying resolution request nbma src:10.10.20.202 nbma dst:10.10.21.110 reason:IPSEC-IFC: need to wait for IPsec SAs.

Jan 2 09:50:31.384: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel152 netid-out 152

Jan 2 09:50:31.384: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:31.384: NHRP: Found node for 10.152.20.108 (as dst)

Jan 2 09:50:31.384: NHRP: Resolution Request not queued. Already being processed (delayed).

Jan 2 09:50:31.384: NHRP: Sending packet to NHS 10.152.20.72 on Tunnel152.

Jan 2 09:50:32.824: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:32.824: NHRP: Found node for 10.152.20.108 (as dst)

Jan 2 09:50:32.824: NHRP: Resolution Request not queued. Already being processed (delayed).

Jan 2 09:50:33.384: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel152 netid-out 152

Jan 2 09:50:33.384: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:33.384: NHRP: Found node for 10.152.20.108 (as dst)

Jan 2 09:50:33.384: NHRP: Resolution Request not queued. Already being processed (delayed).

Jan 2 09:50:33.388: NHRP: Sending packet to NHS 10.152.20.72 on Tunnel152.

Jan 2 09:50:35.384: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel152 netid-out 152

Jan 2 09:50:35.384: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:35.384: NHRP: Found node for 10.152.20.108 (as dst)

Jan 2 09:50:35.384: NHRP: Resolution Request not queued. Already being processed (delayed).

Jan 2 09:50:35.388: NHRP: Sending packet to NHS 10.152.20.72 on Tunnel152

Jan 2 09:50:35.856: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:35.856: NHRP: Found node for 10.152.20.108 (as dst)

Jan 2 09:50:35.856: NHRP: Resolution Request not queued. Already being processed (delayed)..

Jan 2 09:50:37.384: NHRP: MACADDR: if_in null netid-in 0 if_out Tunnel152 netid-out 152

Jan 2 09:50:37.384: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:37.384: NHRP: Found node for 10.152.20.108 (as dst)

Jan 2 09:50:37.384: NHRP: Resolution Request not queued. Already being processed (delayed).

Jan 2 09:50:37.388: NHRP: Sending packet to NHS 10.152.20.72 on Tunnel152.

Success rate is 20 percent (1/5), round-trip min/avg/max = 84/84/84 ms

GUANRT01#

Jan 2 09:50:42.432: NHRP: Checking for delayed event 0.0.0.0/10.152.20.108 on list (Tunnel152).

Jan 2 09:50:42.432: NHRP: Found node for 10.152.20.108 (as dst)

Jan 2 09:50:42.432: NHRP: Resolution Request not queued. Already being processed (delayed).

New Member

Re: DMVPN NHRP porblem

Debug at Shanghai

Jan 2 09:50:31.333: NHRP: Receive Resolution Request via Tunnel152 vrf 0, packet size: 83

Jan 2 09:50:31.333: NHRP: netid_in = 152, to_us = 0

Jan 2 09:50:31.337: NHRP: NAT-check: matched destination address 10.10.20.202

Jan 2 09:50:31.337: NHRP: nhrp_rtlookup yielded Tunnel152

Jan 2 09:50:31.337: NHRP: netid_out 152, netid_in 152

Jan 2 09:50:31.337: NHRP: nhrp_cache_lookup_comp returned 0x64705454

Jan 2 09:50:31.337: NHRP: Attempting to send packet via DEST 10.152.20.200

Jan 2 09:50:31.337: NHRP: Encapsulation succeeded. Tunnel IP addr 10.10.20.202

Jan 2 09:50:31.337: NHRP: Send Resolution Reply via Tunnel152 vrf 0, packet size: 111

Jan 2 09:50:31.337: src: 10.152.20.72, dst: 10.152.20.200

Jan 2 09:50:31.337: NHRP: 111 bytes out Tunnel152

Jan 2 09:50:31.373: NHRP: Receive Resolution Request via Tunnel152 vrf 0, packet size: 83

Jan 2 09:50:31.373: NHRP: netid_in = 152, to_us = 0

Jan 2 09:50:31.373: NHRP: NAT-check: matched destination address 10.10.21.110

Jan 2 09:50:31.373: NHRP: nhrp_rtlookup yielded Tunnel152

Jan 2 09:50:31.373: NHRP: netid_out 152, netid_in 152

Jan 2 09:50:31.373: NHRP: nhrp_cache_lookup_comp returned 0x646D67E0

Jan 2 09:50:31.373: NHRP: Attempting to send packet via DEST 10.152.20.108

Jan 2 09:50:31.373: NHRP: Encapsulation succeeded. Tunnel IP addr 10.10.21.110

SHANRT01#

Jan 2 09:50:31.373: NHRP: Send Resolution Reply via Tunnel152 vrf 0, packet size: 111

Jan 2 09:50:31.373: src: 10.152.20.72, dst: 10.152.20.108

Jan 2 09:50:31.373: NHRP: 111 bytes out Tunnel152

SHANRT01#

Jan 2 09:50:43.580: NHRP: Checking for delayed event 0.0.0.0/10.152.20.96 on list (Tunnel152).

Jan 2 09:50:43.580: NHRP: No node found.

Jan 2 09:50:43.580: NHRP: Attempting to send packet via DEST 10.152.20.96

Jan 2 09:50:43.580: NHRP: Send Resolution Request via Tunnel152 vrf 0, packet size: 83

Jan 2 09:50:43.580: src: 10.152.20.72, dst: 10.152.20.96

Jan 2 09:50:43.580: NHRP: Encapsulation failed for destination 10.152.20.96 out Tunnel152

New Member

Re: DMVPN NHRP porblem

configuration:

Guangzhou:

interface Tunnel152

description Multipoint GRE tunnel for hub

bandwidth 128

ip address 10.152.20.200 255.255.0.0

no ip redirects

ip mtu 1428

ip nbar protocol-discovery

ip nhrp authentication ******

ip nhrp map multicast 10.10.10.152

ip nhrp map 10.152.20.72 10.10.10.152

ip nhrp network-id 152

ip nhrp holdtime 300

ip nhrp nhs 10.152.20.72

ip route-cache flow

delay 300000

qos pre-classify

tunnel source Serial0

tunnel mode gre multipoint

tunnel key ****

tunnel protection ipsec profile VPN shared

router eigrp 108

network 10.128.0.0 0.127.255.255

network 172.16.0.0 0.15.255.255

network 192.168.1.0

no auto-summary

Shenzhen

interface Tunnel152

description Multipoint GRE tunnel for Shanghai-hub

bandwidth 128

ip address 10.152.20.108 255.255.0.0

no ip redirects

ip mtu 1428

ip nbar protocol-discovery

ip nhrp authentication *******

ip nhrp map multicast 10.10.10.152

ip nhrp map 10.152.20.72 10.10.10.152

ip nhrp network-id 152

ip nhrp holdtime 300

ip nhrp nhs 10.152.20.72

ip route-cache flow

delay 200000

qos pre-classify

tunnel source Serial0/0/0

tunnel mode gre multipoint

tunnel key ***

tunnel protection ipsec profile VPN shared

network 10.128.0.0 0.127.255.255

network 172.16.0.0 0.15.255.255

network 192.168.3.0

no auto-summary

Beijing

interface Tunnel152

description Multipoint GRE tunnel for hub

bandwidth 128

ip address 10.152.20.88 255.255.0.0

no ip redirects

ip mtu 1428

ip nbar protocol-discovery

ip nhrp authentication ******

ip nhrp map multicast 10.10.10.152

ip nhrp map 10.152.20.72 10.10.10.152

ip nhrp network-id 152

ip nhrp holdtime 300

ip nhrp nhs 10.152.20.72

ip route-cache flow

delay 300000

qos pre-classify

tunnel source Serial0/0/0

tunnel mode gre multipoint

tunnel key ****

tunnel protection ipsec profile VPN shared

end

router eigrp 108

network 10.128.0.0 0.127.255.255

network 172.16.0.0 0.15.255.255

network 192.168.3.0

no auto-summary

468
Views
0
Helpful
3
Replies
CreatePlease to create content