Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DMZ access and VPN termination on it

Hy all.

This is my network:

Inside: 172.18.0.0 255.255.0.0

Dmz: 192.168.50.0 255.255.255.0

Outside: 80.80.80.112 255.255.255.240

This is my problem:

I need access from Inside to Dmz but not fron Dmz to Inside (now don't work)

I need terminate VPN for user COMM1 to DMZ (now don't work)

This is my configuration:

PIX Version 6.3(1)

interface ethernet0 10baset

interface ethernet1 auto

interface ethernet2 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

nameif ethernet2 dmz security10

enable password *** encrypted

passwd ****encrypted

hostname PIX

domain-name intranet

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

names

access-list outside permit icmp any any echo-reply

access-list outside permit tcp any host 80.80.80.126 eq 8020

access-list nonat permit ip 172.18.0.0 255.255.0.0 10.0.4.0 255.255.255.0

access-list nonat permit ip 192.168.50.0 255.255.255.0 10.0.1.0 255.255.255.0

pager lines 21

mtu outside 1500

mtu inside 1500

mtu dmz 1500

ip address outside 80.80.80.114 255.255.255.240

ip address inside 172.18.1.254 255.255.0.0

ip address dmz 192.168.50.254 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool Comm1 10.0.1.1-10.0.1.20

ip local pool Networking 10.0.4.1-10.0.4.20

pdm location 172.18.0.0 255.255.0.0 inside

pdm location 172.18.0.0 255.255.255.255 inside

pdm location 192.168.50.0 255.255.255.0 inside

pdm location 10.0.1.0 255.255.255.0 outside

pdm location 10.0.4.0 255.255.255.0 outside

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list nonat

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

nat (dmz) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) 80.80.80.126 172.18.1.4 netmask 255.255.255.255 0 0

access-group outside in interface outside

route outside 0.0.0.0 0.0.0.0 80.80.80 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 172.18.0.0 255.255.255.255 inside

http 172.18.0.0 255.255.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set TRSET esp-3des esp-sha-hmac

crypto dynamic-map dynmap 10 set transform-set TRSET

crypto map VPN 10 ipsec-isakmp dynamic dynmap

crypto map VPN interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash sha

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup Comm1 address-pool Comm1

vpngroup Comm1 idle-time 1800

vpngroup Comm1 password ********

vpngroup Networking address-pool Networking

vpngroup Networking dns-server 172.18.1.5 172.18.1.2

vpngroup Networking wins-server 172.18.1.5 172.18.1.2

vpngroup Networking default-domain intranet

vpngroup Networking idle-time 1800

vpngroup Networking password ********

telnet 172.18.0.0 255.255.0.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

terminal width 80

2 REPLIES
Cisco Employee

Re: DMZ access and VPN termination on it

For access from inside to dmz do the following:

> global (dmz) 1 interface

Not sure whatyou mean by terminating the VPN on the DMZ, the DMZ has a RFC1918 address so it's not going to be routable for a user out on the Internet. If you mean you want to terminate the VPN on the outside interface, but have the user access the DMZ, then add:

> nat (dmz) 0 access-list nonat

New Member

Re: DMZ access and VPN termination on it

Tank you for answer.

+ I do the following:

access-list nonat permit ip 172.18.0.0 255.255.0.0 192.168.50.0 255.255.255.0

Now all works fine!

Tks again.

136
Views
0
Helpful
2
Replies