Cisco Support Community
Community Member

Firewall port 80 opened on external interface issue

I can't seem to find why port 80 and 21 on my PIX 501's external interface is opened. But not on 515e with almost similar configuration.

I can telnet FW-EXTERNAL-IP port 80 and 21.

PIX Version 6.3(4)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxxxxxxxxxxx encrypted

passwd xxxxxxxxxxxxx encrypted



fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69


access-list acl_vpn permit ip

access-list acl_inside permit tcp any eq www

access-list acl_inside permit tcp any eq lotusnotes

access-list acl_inside permit icmp any

access-list acl_inside permit tcp any eq ssh

access-list acl_inside permit tcp any eq domain

access-list acl_inside permit udp any eq domain

access-list acl_inside permit tcp any eq 1863

access-list acl_inside permit tcp any eq https

access-list acl_outside permit icmp any any

pager lines 24

logging on

logging trap debugging

logging host inside

mtu outside 1500

mtu inside 1500

ip address outside XXX.XXX.XXX.XXX

ip address inside

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 XXX.XXX.XXX.XXX

nat (inside) 0 access-list acl_vpn

nat (inside) 1 0 0

access-group acl_outside in interface outside

access-group acl_inside in interface inside

route outside 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-3des esp-md5-hmac

crypto map mymap 1 ipsec-isakmp

crypto map mymap 1 match address acl_vpn

crypto map mymap 1 set peer XXX.XXX.XXX.XXX

crypto map mymap 1 set transform-set myset

crypto map mymap interface outside

isakmp enable outside

isakmp key ******** address XXX.XXX.XXX.XXX netmask

isakmp identity address

isakmp policy 1 authentication pre-share

isakmp policy 1 encryption 3des

isakmp policy 1 hash md5

isakmp policy 1 group 1

isakmp policy 1 lifetime 3600

telnet inside

telnet timeout 5

ssh outside

ssh outside

ssh inside

ssh timeout 60

console timeout 0

dhcpd address inside

dhcpd dns

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd enable inside

terminal width 80


: end

Please assist




Re: Firewall port 80 opened on external interface issue

You cannot telnet to outside interface of PIX you can use only SSH

command ssh outside permits traffic to outside so you can connect with SSH client if you dont have SSH try putty from following link


You need enable access to outside interface

http outside

This command allows to all outside IP access to PIX via PDM (after authentication with username/password)

If you want specify access only to specific host (IP x.x.x.x)

You can do it in this way:

http x.x.x.x outside


Hope that helps rate if it does


Community Member

Re: Firewall port 80 opened on external interface issue

Hi M.sir,

Thanks for your quick reply, unfortunately you misunderstood my question/issue.

My firewall's public IP address on the outside interface has port 80 opened. I can run the following command to see that port 80 is opened.

telnet 80

My ethereal result also shows a successful TCP connection handshake. The problem is that I cannot seem to find where is the configuration that opens the firewall port 80 on outside interface.

I have already tried following command

pixfirewall(config)#no http server enable

I can SSH to my firewall, its not the issue. Not intending to use PDM from the outside interface also.

All please assist,



CreatePlease to create content