Cisco Support Community
Community Member

FWSM software upgrade

Hi All

I need advice on FWSM software upgrade to version 3.1. Please see attachment for details.

Thanks & regards


Re: FWSM software upgrade

Hello Tutinco,

For having 3.1 IOS, you just need to have approprite images on the Supervisor engine. 12.2(18)SXF/SXF2/SXF4 images.

Please refer to the release notes of 3.1 IOS:

you dont require FR-SVC-FWM-UPGR3 licenses for normal upgrades, because this license is used only for virual firewalling/security contexts of upto 250 VFW. you dont need to buy anything for this upgrade :)

Hope this helps.. all the best... rate replies if found useful..


Community Member

Re: FWSM software upgrade

Hi Raj

Many thanks for the advice. I will let you know upon the completion of my upgrade.


Community Member

Re: FWSM software upgrade

Hi Raja,

FWSM1# show ver

FWSM Firewall Version 2.3(3)

FWSM Device Manager Version 4.1(1)

Compiled on Mon 10-Oct-05 14:50 by dalecki

WLANFWSM1 up 49 days 12 hours

Hardware: WS-SVC-FWM-1, 1024 MB RAM, CPU Pentium III 1000 MHz

Flash 2.20 TOSHIBA THNCF128MBA @ 0xc321, 20MB

0: gb-ethernet0: irq 5

1: gb-ethernet1: irq 7

2: ethernet0: irq 11

Licensed Features:

Failover: Enabled

VPN-DES: Enabled

VPN-3DES: Enabled

Maximum Interfaces: 256 (per security context)

Cut-through Proxy: Enabled

Guards: Enabled

URL-filtering: Enabled

Throughput: Unlimited

ISAKMP peers: Unlimited

Security Contexts: 20

This machine has an Unrestricted (UR) license.

Can confirmed if we need to purchase additional license as we got 20 security contexts and is running FWSM as:

Active/Standby pair

Routed mode (not transparent FW)

Community Member

Re: FWSM software upgrade


Can someone please advice?


CreatePlease to create content