Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

GRE and DHCP assigned IP address

Is it possible to have a dynamic destination with a GRE tunnel? I have one end of a tunnel that is assigned a DHCP address by a service provider and I want to use a GRE tunnel to connect this router to another router on the Internet.

3 REPLIES
Cisco Employee

Re: GRE and DHCP assigned IP address

This is possible with a new feature called Dynamic Multipoint VPN (DMVPN) in 12.2(13)T. See here for details:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftgreips.htm

It's designed for large hub and spoke environments where the spoke IP address is not known and to limit the config size of the hub, but it should be just as useful in your environment.

New Member

Re: GRE and DHCP assigned IP address

Thanks for the response. It looks like this method requires IPSec to run, and I just want to use GRE. Can this be used for GRE only? The software I have doesn't have the DES/3DES feature set.

Cisco Employee

Re: GRE and DHCP assigned IP address

This will work just with plain GRE, you don't have to encrypt it as well. Your hub (the router with the known IP address) would look like this:

interface Tunnel0

ip address 172.16.1.1 255.255.255.0

no ip redirects

ip nhrp authentication cisco123

ip nhrp map multicast dynamic

ip nhrp network-id 1

tunnel source Ethernet0/0

tunnel mode gre multipoint

tunnel key 10000

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

and your spoke (the router doing DHCP), would look like this:

interface Tunnel0

ip address 172.16.1.2 255.255.255.0

ip nhrp authentication cisco123

ip nhrp map 172.16.1.1 10.1.1.1

ip nhrp map multicast 10.1.1.1

ip nhrp network-id 1

ip nhrp nhs 172.16.1.1

tunnel source Ethernet0/0

tunnel destination 10.1.1.1

tunnel key 10000

!

interface Ethernet0/0

ip address dhcp

You can then run any routing protocol you like and include the 172.16.1.0 network under that routing protocol, that way routing updates will go across the tunnel and everything should be fine.

227
Views
0
Helpful
3
Replies
CreatePlease to create content