Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with PIX config not working

I work for a local ISP and am putting in my first PIX. i have posted several times before and keep getting closer but something still dosnt seem to be right. Right now we have our backbone with a 206.x.74.1 address on the ethernet and 206.x.74.5 on our side. what i plan on doing is changing the ethernet on there side to 10.10.10.1 and making the outside interface of the firewall 10.10.10.2. Then my inside of the PIX will be 206.x.74.1. Our customers use the .74 and another subnet, the .211 for dialing into our service. The 74.3, 74.5 and 208.8 are servers that our cusomers will need to access certain ports on for certain services. Anyone on the inside of the firewall is our office and would need to be allowed to access the outside world. I am pretty positive that one thing i am missing is a route inside statement. but other than that i dont know of anything i might have done wrong. any suggestions on anything would be greatly appreciated.

thank you

mike

PIX Version 6.1(4)

nameif ethernet0 outside security0

nameif ethernet1 inside security100

nameif ethernet2 intf2 security10

nameif ethernet3 intf3 security15

nameif ethernet4 intf4 security20

nameif ethernet5 intf5 security25

enable password Vc5SuIC5HTy5.dBK encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname PIXFirewall

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 1720

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list 101 permit ip 206.x.74.0 255.255.255.0 206.x.211.0 255.255.255.0

access-list 101 permit ip 206.x.74.0 255.255.255.0 206.x.74.0 255.255.255.0

access-list inbound_connect permit tcp any host 206.x.208.8 eq www

access-list inbound_connect permit tcp any host 206.x.208.8 eq 443

access-list inbound_connect permit tcp any host 206.x.208.8 eq ftp

access-list inbound_connect permit tcp any host 206.x.208.8 eq domain

access-list inbound_connect permit tcp any host 206.x.208.8 eq 799

access-list inbound_connect permit udp any host 206.x.208.8 eq domain

access-list inbound_connect permit udp any host 206.x.208.8 eq snmp

access-list inbound_connect permit tcp any host 206.x.74.3 eq www

access-list inbound_connect permit tcp any host 206.x.74.3 eq 443

access-list inbound_connect permit tcp any host 206.x.74.3 eq ftp

access-list inbound_connect permit tcp any host 206.x.74.3 eq 5800

access-list inbound_connect permit tcp any host 206.x.74.3 eq 1815

access-list inbound_connect permit tcp any host 206.x.74.3 eq 1814

access-list inbound_connect permit tcp any host 206.x.74.5 eq 799

access-list inbound_connect permit tcp any host 206.x.74.5 eq 1815

access-list inbound_connect permit tcp any host 206.x.74.5 eq 1814

access-list inbound_connect permit udp any host 206.x.74.5 eq 45

access-list inbound_connect permit icmp any any echo

access-list inbound_connect permit icmp any any echo-reply

pager lines 24

interface ethernet0 auto

interface ethernet1 auto

interface ethernet2 auto shutdown

interface ethernet3 auto shutdown

interface ethernet4 auto shutdown

interface ethernet5 auto shutdown

mtu outside 1500

mtu inside 1500

mtu intf2 1500

mtu intf3 1500

mtu intf4 1500

mtu intf5 1500

ip address outside 10.10.10.2 255.255.255.0

ip address inside 206.x.74.1 255.255.255.0

ip address intf2 127.0.0.1 255.255.255.255

ip address intf3 127.0.0.1 255.255.255.255

ip address intf4 127.0.0.1 255.255.255.255

ip address intf5 127.0.0.1 255.255.255.255

ip audit info action alarm

ip audit attack action alarm

no failover

failover timeout 0:00:00

failover poll 15

failover ip address outside 0.0.0.0

failover ip address inside 0.0.0.0

failover ip address intf2 0.0.0.0

failover ip address intf3 0.0.0.0

failover ip address intf4 0.0.0.0

failover ip address intf5 0.0.0.0

pdm history enable

arp timeout 14400

nat (inside) 0 access-list 101

access-group inbound_connect in interface outside

route outside 0.0.0.0 0.0.0.0 10.10.10.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si

p 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

no sysopt route dnat

telnet 0.0.0.0 0.0.0.0 inside

telnet timeout 5

ssh timeout 5

terminal width 80

Cryptochecksum:b6bd3bab2112f76c9b3f72dd1a3ab881

: end

[OK]

PIXFirewall#

2 REPLIES
New Member

Re: Help with PIX config not working

o.k. so far i have found one think i think is wrong. i was confused on how the nat statement worked and have since then change it. now i have acl's for the ip addresses i want to be allowed to the outside of the firewall and have mapped them with the nat 0 (inside) command. now i just need to make static translations for the servers on the jnside and all should work i think. does this sound right so far to anyone?

New Member

Re: Help with PIX config not working

What exactly is not working?

Basic connectivity?

Translation?

What does the new config look like?

I find it best to start from the begining when troubleshooting.

(Assuming you are not live or have down time)

Put a basic config in test add a configuration test until your config does not do what you want or expect.

81
Views
0
Helpful
2
Replies