Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

hub to spoke dmvpn, ip nhrp map commands

Consider the setup one hub and one spoke. I've tried 2 different configuration methods on the spoke and both seem to work. But I don't understand why then you need the extra commands 'nhrp map ...'

There's ospf running between the sites

spoke

setup 1

interface Tunnel2

description *** internet tunnel ***

ip address 10.1.166.99 255.255.255.240

ip mtu 1380

ip nhrp network-id 4

ip nhrp holdtime 900

ip nhrp nhs 10.1.166.97

ip nhrp registration timeout 30

ip ospf network broadcast

ip ospf cost 100

ip ospf priority 0

tunnel source Loopback2

tunnel destination 10.255.1.1

tunnel key 4

!

setup 2

interface Tunnel2

description *** internet tunnel ***

ip address 10.1.166.99 255.255.255.240

ip mtu 1380

ip nhrp map 10.1.166.97 10.255.1.1

ip nhrp map multicast 10.255.1.1

ip nhrp network-id 4

ip nhrp holdtime 900

ip nhrp nhs 10.1.166.97

ip nhrp registration timeout 30

ip ospf network broadcast

ip ospf cost 100

ip ospf priority 0

tunnel source Loopback2

tunnel destination 10.255.1.1

tunnel key 4

hub

interface Tunnel2

description *** internet tunnel ***

ip address 10.1.166.97 255.255.255.240

no ip redirects

ip mtu 1380

ip nhrp map multicast dynamic

ip nhrp network-id 4

ip nhrp holdtime 900

ip nhrp server-only

ip ospf network broadcast

ip ospf cost 100

ip ospf priority 5

tunnel source 10.255.1.1

tunnel mode gre multipoint

tunnel key 4

thx

elke

1 REPLY
Bronze

Re: hub to spoke dmvpn, ip nhrp map commands

This document provides a sample configuration for Dynamic Multipoint VPN (DMVPN) using generic routing encapsulation (GRE) over IPsec with Open Shortest Path First (OSPF), Network Address Translation (NAT), and Cisco IOS? Firewall.

http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a008019d6f7.shtml

736
Views
0
Helpful
1
Replies
CreatePlease login to create content