Cisco Support Community
Community Member

IDS UPDATE Disk Space Error for 3.1.1-S22

Is anyone else getting this error message while trying to update from 3.0.5-S21 to 3.1.1-S22 on their sensors? Please advise. (see bellow).

# ./IDSk9-sp-3.1-1-S22.bin -I

Performing disk space checks.....

ids-patchinstall: Error, the update requires 112000 KB in /usr/nr, there are only 77145 KB available.

ids-patchinstall: The Update cannot continue. No Changes have been made.

# df -k

Filesystem kbytes used avail capacity Mounted on

/dev/dsk/c0d0s0 245980 17213 204169 8% /

/dev/dsk/c0d0s6 491977 181773 261007 42% /usr

/proc 0 0 0 0% /proc

fd 0 0 0 0% /dev/fd

mnttab 0 0 0 0% /etc/mnttab

/dev/dsk/c0d0s3 245980 7202 214180 4% /var

swap 804116 4 804112 1% /var/run

swap 914416 110304 804112 13% /tmp

/dev/dsk/c0d0s5 245980 1510 219872 1% /opt

/dev/dsk/c0d0s7 4377769 37929 4296063 1% /usr/nr/var

Cisco Employee

Re: IDS UPDATE Disk Space Error for 3.1.1-S22

The 3.1.1S22 service pack requires 297 MB of free disk space in the /usr partition to install.

1) When you copied the IDSk9-sp-3.1-1-S22.bin file to your sensor, make sure it is in /usr/nr/var or /tmp and NOT /usr or /usr/nr. The /usr/nr/var is a separate paritition with plenty of space. If you copied it to /usr/nr, do a "mv /usr/nr/IDSk9-sp-3.1-1-S22.bin /usr/nr/var".

2) You need a total of 297 MB of free disk space in the /usr partition to install the service pack. You can remove the /usr/nr/sp-update directory to free up disk space.

rm-rf /usr/nr/sp-update

If you now have enough free space , run the installer again.

cd /usr/nr/var

./IDSk9-sp-3.1-1-S22.bin -I

If you still do not have enough free space, you can sym-link the installation directories to /usr/nr/var

rm -rf /usr/nr/sp-update

mkdir /usr/nr/var/sp-update

mkdir /usr/nr/var/33-update

ln -s /usr/nr/var/sp-update /usr/nr/sp-update

ln -s /usr/nr/var/33-update /usr/nr/33-update

That should definitely do it, now you can run the installer

cd /usr/nr/var

./IDSk9-sp-3.1-1-S22.bin -I

Community Member

Re: IDS UPDATE Disk Space Error for 3.1.1-S22

Yes, I did the same today but got the same error. Have you found an answer about a work-around. It looks like it has to do with UNIX but I have limited knowledge on commands for Unix. I just opened a TAC case hopefully they call me back soon. I'll check back.

Cisco Employee

Re: IDS UPDATE Disk Space Error for 3.1.1-S22

There is a bug in the install that checks for an incorrect amount of diskspace.

The install checks disk space in many places and in taht particular place it is checking for that amount, but what the user doesn't know is that it has already placed more than 170000 KB of files in /usr/nr prior to that check, so when the check is made there is less than 112000 KB.

After the error it cleans itself up and removes the other 170000 KB you didn't know about.

So for the install to work properly you have to start out with at least 300000 KB (297000 KB is what I've been told) in /usr/nr.

You have only 261007 free in /usr.

You will need to clean up at least 30000 KB from /usr.

Look at the 4th field from your df -k output.

/dev/dsk/c0d0s6 491977 181773 261007 42% /usr

Things to do to clean up some space:

remove the /usr/ciscosec directory (some old sensors still have this directory and it is not needed)

remove the /usr/nr/sp-update and /usr/nr/sig-update directories (these directories have backups of files from previous installs, removing them will prevent you from uninstalling current versions)

remove files from the /usr/nr/etc/backups directory (these are old config files that were archived during previous installs.)

remove any files that you may have created

NOTE: the files in /usr/nr/var are in a different partition and will not affect the install and space in /usr.

Let me know if this still doesn't give you enough space, and I will see what else needs to be deleted.


CreatePlease to create content