Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Internet Explorer - ASA 5520

Hi,

I have a trick case with a ASA 5520 and a intranet in Internet Explorer. There is a picture, flash and document manager and the trafic get blocked when using IE, but not in Firefox. The intranet is using port 80. Anyone else seen something like this?

31 REPLIES

Re: Internet Explorer - ASA 5520

Most probably the issue is not with the firewall (ASA) and the real issue lies in the browser settings.

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi,

Thanks for your quick replay.

I tought so to but the intranet is funktion quite well outside the network ex. from my home net. And i get an Access Denied in the ASA logg on traffic to the intranet when i use IE inside my net, but strangely not in Firefox.

Re: Internet Explorer - ASA 5520

Please give more details about the topology, configuration/inspections enabled on the ASA.

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Http inspection has default settings.

Her are the message i get in tha ASA logg when using IE.

Deny TCP (no connection) from x.x.x.x/2997 to x.x.x.x/80 flags ACK on interface Innside

Deny TCP (no connection) from x.x.x.x/2997 to x.x.x.x/80 flags FIN ACK on interface Innside

Teardown TCP connection 197682186 for Internett:x.x.x.x/80 to Innside:x.x.x.x/2997 duration 0:00:28 bytes 304213 Flow closed by inspection

Access denied URL SRC x.x.x.x DEST x.x.x.x on interface Innside

This is regular http traffic and it is working in Firefox from the same pc and settings.

Re: Internet Explorer - ASA 5520

The logs seem to come from the Internet and not the Intranet?

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

This message comes from the webserver hosting the intranet.

Teardown TCP connection 197682186 for Internett:x.x.x.x/80 to Innside:x.x.x.x/2997 duration 0:00:28 bytes 304213 Flow closed by inspection

I can't understand why inspection is closing the connection when IE is used, but works in FF. Maybe it is something in the way browser handlling the site and is there anything we can set in ASA to prevent/allow this?

Re: Internet Explorer - ASA 5520

I'm still not clear with your topology.

On which zone is your web server? "Internett" zone? From where are you testing ? LAN = "Innside"?

Which version of ASA are you running?

What do you have under IE:

IE >> Tools >> Advanced >> HTTP 1.1 Settings

Regards

farrukh

New Member

Re: Internet Explorer - ASA 5520

The webserver are not in "my net". We are delivering applications via Citrix to our users. I am testing this from my inside, with the same setting the users have.

So the traffic are like this:

Terminal Server -> ASA -> Internet -> Webserver

ASA version: ASA 5520 with image asa721-k8

And we are using http 1.1 settings

Re: Internet Explorer - ASA 5520

Can you try permitting this 'return' traffic or disabling the HTTP inspection to test this out?

New Member

Re: Internet Explorer - ASA 5520

Hi again,

I am not very experienced with ASA, so how would turning of http inspection affect the rest of the traffic?

Re: Internet Explorer - ASA 5520

Disabling should not affect other traffic, but just to be on the safe side you can just disable it for your specific server, please have a look at:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a008085283d.shtml

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi,

Have tried the suggested solutions, but still same errors in the asa log. I have tried with a new asa 5505 with default settings and there it is working, the only differens is that it is a newer image on the 5505 (7.2(2))

Best Regards

Re: Internet Explorer - ASA 5520

Can you post the output of the following command from both boxes:

show run all policy-map

show run service-policy

Then on the troublesome box,

clear asp drop

immediately test the problematic server connection via IE, then paste output of

show asp drop

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi, Farrukh,

Will do that tomorrow, thanks for your replay.

Regards

New Member

Re: Internet Explorer - ASA 5520

Hi again,

Attched txt file with info as described above.

Re: Internet Explorer - ASA 5520

Please add the following command on the 5520 box:

policy-map global_policy

class inspection_default

inspect http

Also can you do the clear asp drop and show asp drop a little quicker? :). It seems a lot of other traffic also came about (I know this might not be possible on a busy production box).

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi,

I have tried to add inspect http, but with the same result. I will try to do a clear asp drop on nighttime, with less traffic:-)

regards

New Member

Re: Internet Explorer - ASA 5520

Hi,

Attched are the result of clear asp drop last night.

Re: Internet Explorer - ASA 5520

Any updates on this issue? I would capture both IE/Firefox traffic using a packet sniffer and compare the two. You can also use the capture command on the ASA with the asp-drop keyword

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi,

I have not found the time for testing, but it seems like FF is requesting on port 3840 and IE on port 3807. But lately we have had some websites turning up "white" with the status line showing "Done". Wondering if this is the same issue.

Regards

Re: Internet Explorer - ASA 5520

The port number should not make a difference

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi again,

No, i know, but it is the only difference i see. Another possibilty is the way the browser acctually "reads" the different webpages.

Re: Internet Explorer - ASA 5520

Did you try permitting the traffic in both directions? (assuming the firewall to be a stateless pakcet filter e.g. ACL)

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi,

Yes, i tried that, we see on another websites that turns up "white" that the ASA logs an Acess Denied with Flow Closed By Inspection message the first time, when they press F5 the webpages come up the way they should. Strange. It seems that something in this traffic from IE is not the way it should be. Also, Wireshark logs Bad Checksum on this traffic. FF is working from the same computer to the same site seconds after.

Regards

Re: Internet Explorer - ASA 5520

Double check for any MTU/speed/duplex issues. Specially on the server's interface connected to the switch.

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi,

Found a solution, If i enable a expect rule in filter properties that say to truncate url for the spesific web server it works in both browsers. But, can you tell me the issues about truncat long urls?

Regards

Re: Internet Explorer - ASA 5520

The url-truncate feature is only applicable when you have the 'filter url' command configured as far as I know. For more information have a look at this link:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a008088517b.shtml#task3

Regards

Farrukh

New Member

Re: Internet Explorer - ASA 5520

Hi,

We are using a filterign server. Serveral of my cases with IE browsing trouble was solved when i made an exception for the trouble webservers (pages).

But, what is the security issues with url-truncate?

Thank you very much for your help so far.

Regards

Re: Internet Explorer - ASA 5520

As I said earlier, I doubt the URL-truncation is causing the problem. The longurl-deny argument is the one really used to control the security (because some very long URLs can embed scripts etc.)

"The longurl-truncate option causes the security appliance to send only the host name or IP address portion of the URL for evaluation to the filtering server when the URL is longer than the maximum length permitted."

424
Views
0
Helpful
31
Replies