Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Is PPPoE supported on C3640?

I had a opened a case with cisco on this (Case# D240540) but was closed while I was on sick leave.

Here is cap-up of the problem with pppoe over Fastethernet on the Cisco 3640 router. Essentially, we intend to use one of the 2 Fastethernet ports on the C3640 to do VPDN over DSL to a service provider.

1. The Cisco3640 was delivered with the IOS file "c3640-is-mz.122-10b.bin"

(We have checked at the Feature Navigator and this software is listed to do VPDN and pppoe)

2. Here is a sketch of how we wanted to configure the router for PPPoe over Fastethernet for use with a DSL (btw. the DSL line from the service provider is working, because we only replaced an ELSA-Router which is presently using the line).

---

Vpdn enable

Vpdn group (#)

Request dialin

Protocol pppoe ! --- This command wasn't recognised by the C3640 Router

Interface FastEthernet 1/0

! --- (We also tried with subinterfaces - in vain)

Pppoe enable

Pppoe-client dial-pool-number 1 ! --- This command wasn't accepted either

Interface dialer 1

Ip address negotiated

Ip mtu 1492

Ppp authentication (protocol)

Dialer pool 1

Dialer-group 1

Dialer-list 1 protocol ip permit

---

3. Then we upgraded to the IOS "T"-chain as Cisco suggested. The IOS c3640-is-mz.122-11.T.bin did not "see" the Fastethernet port!

4. Then c3640-is-mz.122-8.T5.bin did "see" the Fastethernet port but our Callback configuration (which is an additional function of the router in the Network) did not work (nor the PPPoe)

5. So we reverted to the initial IOS (c3640-is-mz.122-10b.bin). Now the Callback worked. However, as usual, pppoe over fastethernet didn't work.

6. We have also tried c3640-is-mz.121-17.bin -in vain!

7. Has anyone successfully tried to do VPDN (ie PPover FastEthernet) on a C3640 to dial to an ISP on a DSL line and has any advice to give me?

Thanks in advance.

Daniel Kutchin

1 REPLY
Community Member

Re: Is PPPoE supported on C3640?

Your best bet is to just re-open your tac case.

337
Views
0
Helpful
1
Replies
CreatePlease to create content