Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

linux vpnclient and Mandrake 10.0

I'm having trouble getting the linux vpnclient to run on a machine running Mandrake 10.0 (with the 2.6 kernel). It installed with no errors, and re-compiled the kernel module (I assume). When I run the init.d script to start the vpn services, and do "lsmod |grep -i cisco" I see the kernel module, anyway. :-)

But when I run vpnclient connect my_profile_name, it prompts me for the group password, then hangs after I enter it. At that point, I can't kill vpnclient, can't do things like ifconfig, and can't shut down the machine cleanly - I assume because of a problem with the kernel module?

Is anyone running the linux vpnclient ok with a 2.6 kernel? Any ideas of what could be wrong?

7 REPLIES
New Member

Re: linux vpnclient and Mandrake 10.0

A bit more information...

The vpn client actually says "Initializing the VPN connection." before it hangs, and if I wait long enough, I also get this error:

The VPN sub-system is busy or has failed.

I suspect it's failed. :-) I can't rmmod it and all sorts of things (like ifconfig) hang until I power cycle the machine.

Also, in /var/log/messages, I see some notification about the kernel module loading, a warning about it "tainting" the kernel (heh heh), and then I get this error:

localhost net.agent[3066]: add event not handled

Could this be when it tries to add a new virtual interface and apparently can't? I think I did see a new interface in the ifconfig output after I ran /etc/init.d/vpnclient_init start and before I ran vpnclient connect...

Ideas, anyone?

Brent

New Member

Re: linux vpnclient and Mandrake 10.0

What a coincidence, I'm having the same issue w/my new Mandrake 10 install. It appears that the service does not start, at boot or if I run it manually, and I would assume that is the reason for the client hanging the system. Here are the excerpts from my messages log:

kernel: cisco_ipsec: no version magic, tainting kernel.

kernel: cisco_ipsec: module license 'Proprietary' taints kernel.

kernel: Cisco Systems VPN Client Version 4.0.3 (B) kernel module loaded

net.agent[4249]: add event not handled

I'm using the same pcf from my WXP box but I'm wondering if I should drop back to 3.7 since that was the last one posted on my company's site and possibly one that they were able to get working in our environment. Of course the linux client is not supported, but I've been there before. ;>

If anyone can shed some light on this I'd greatly appreciate it.

~Glenn

New Member

Re: linux vpnclient and Mandrake 10.0

Well, more research and I found out the 'tainting' is due to the Cisco license makes the kernel somewhat less than 100% GPL. So that's a dead-end.

I've found some vague references as far back as 2002 to the same error, but it must be one of those 'simplistic' solutions so no one has posted their solution.

vpnclient_init status gives me the following:

Module Size Used by

cisco_ipsec 392108 0

cipsec0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

BROADCAST MULTICAST MTU:1400 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:100

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

However, vpnclient stat paints a different picture:

Cisco Systems VPN Client Version 4.0.3 (B)

Copyright (C) 1998-2003 Cisco Systems, Inc. All Rights Reserved.

Client Type(s): Linux

Running on: Linux 2.6.2-3mdk #1 Fri Feb 13 19:29:11 CET 2004 i686

The VPN sub-system is busy or has failed.

Not sure which direction to go now, the logs don't have squat that I can find. This seems like a newbie problem but darned if I can find the answer.

Help!

~Glenn

New Member

Re: linux vpnclient and Mandrake 10.0

I'm stuck too. I did get the client running today on a Mandrake 9.0 machine with the 2.4.19-16 kernel, so I know I'm not just installing/configuring it wrong. But Mandrake 10.0 with the 2.6.something kernel isn't working at all with the vpn client.

Anonymous
N/A

Re: linux vpnclient and Mandrake 10.0

From what I've read online, you won't be able to get it to work. It is a bug in the precompiled part of the vpnclient.

See this page: http://www.anomalistic.org/

I installed kernel 2.4.25 that ships with 10.0, and installed the 4.0.3 B release of the vpnclient, and it works just fine.

New Member

Re: linux vpnclient and Mandrake 10.0

Ah, thanks for the reply and URL! I just looked at the site you referred to and they say it should work now, with a patched version (also there are references to other vpn clients to try).

I'm running Mandrake 10.0 rc1 (downloading the official 10.0 release now that it's available, to test *it* too). But part of the reason for using this latest Mandrake was for some of the 2.6 kernel and some of the performance improvements it has (good article in SysAdmin magazine 'bout it). Anyway, I'll give the patched version a go and see if that fixes it. Failing that, I'll either roll back to an earlier kernel or will try another vpn client and will report back here when I have a resolution.

New Member

Re: linux vpnclient and Mandrake 10.0

At first glance, the vpnclient found at www.anomalistic.org which apparently contains two patches seems to be working fine with my 2.6.3 kernel. :-) I'm able to connect, and pass packets, anyway.

For the record, the patches (according to the website) that have been applied to the vpnclient are:

1. vpnclient-deadlock-fix-4.0.3.B-k9.patch

2. vpnclient-debian-fixes-4.0.3.B-k9.patch

Thanks, guys!

413
Views
0
Helpful
7
Replies