cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
295
Views
0
Helpful
3
Replies

multiple static's

mraisley
Level 1
Level 1

I am putting in a PIX 515 at an ISP i work for. we have three different subnet's for our dial in account's. i need to map them all to the same inside subnet/IPaddress. how is that done. i first issued this command:

static (inside, outside) 206.x.211.0 206.x.74.0

after that though i need to map another subnet to 206.x.74.0 and then it says it over laps, which i can see. but i dont know what to do then. any suggestions anyone?? thanks for any help

mike

1 Accepted Solution

Accepted Solutions

You are welcome ! Since you have these:

access-list 101 permit ip 206.x.74.0 255.255.255.0 206.x.211.0 255.255.255.0

nat (inside) 0 access-list 101

You don't even need the following line:

static (inside,outside) 206.x.74.0 206.x.74.0 netmask 255.255.255.0 0 0

As nat (inside) 0 ACL will come before the static and with nat (0) acl, you are directing the pix not to use the nat engine at all. So, in nutshell, your config looks good.

One thing I suggest is to do "clear xlate" on the pix and see if that ressolves the issue. If not, then my suggesrion would be run syslog on the pix. That will give all the details of whats going on:

logging on

logging buffered debugging

then execute "show logging" that will give you the details of whats going on?

If the pix is pretty busy then logging info on buffer might not be useful (as buffer has limitations on how much it can store) , in that case, you may want to use the syslog to collect the logging info. here is the link on how to do that:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a0080094030.shtml

I hope this helps ! Thanks,

Mynul

View solution in original post

3 Replies 3

mhoda
Level 5
Level 5

Mike,

Just to have a complete picture, are those three subnets reside on outside of the PIX? Then are you trying to map them to 206.x.74.0 ? Why do you want to do that ? Are those 3 subnets need to communicate with 206.x.74.0 ? If thats the case, then all you need is

static (inside, outside) 206.x.74.0 206.x.74.0

Then create access-list and allow those three networks to inside.

I hope this helps ! Thanks,

Mynul

Yes that is correct. I have three subnet's that are used for dial up account that i would need to be allowed through the firewall to access services on inside servers. Here is what the configuration looks like with the commmand that you helped me with. I dont see any reason why is shouldnt work. Thanks for your help. anything you see wrong i feel free to reply, this is my first firewall. thank you for you help.

mike

: PIX Version 6.1(4)

nameif ethernet0 outside security0

nameif ethernet1 inside security100

nameif ethernet2 intf2 security10

nameif ethernet3 intf3 security15

nameif ethernet4 intf4 security20

nameif ethernet5 intf5 security25

enable password Vc5SuIC5HTy5.dBK encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname PixFirewall

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 1720

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list 101 permit ip 206.x.74.0 255.255.255.0 206.x.211.0 255.255.255.0

access-list 101 permit ip 206.x.74.0 255.255.255.0 192.x.13.0 255.255.255.0

access-list 101 permit ip 206.x.74.0 255.255.255.0 192.x.14.0 255.255.255.0

access-list inbound_connect permit tcp any host 206.x.208.8 eq www

access-list inbound_connect permit tcp any host 206.x.208.8 eq 443

access-list inbound_connect permit tcp any host 206.x.208.8 eq ftp

access-list inbound_connect permit tcp any host 206.x.208.8 eq domain

access-list inbound_connect permit tcp any host 206.x.208.8 eq 799

access-list inbound_connect permit udp any host 206.x.208.8 eq domain

access-list inbound_connect permit udp any host 206.x.208.8 eq snmp

access-list inbound_connect permit tcp any host 206.x.74.3 eq www

access-list inbound_connect permit tcp any host 206.x.74.3 eq 443

access-list inbound_connect permit tcp any host 206.x.74.3 eq ftp

access-list inbound_connect permit tcp any host 206.x.74.3 eq 5800

access-list inbound_connect permit tcp any host 206.x.74.3 eq 1815

access-list inbound_connect permit tcp any host 206.x.74.3 eq 1814

access-list inbound_connect permit tcp any host 206.x.74.5 eq 799

access-list inbound_connect permit tcp any host 206.x.74.5 eq 1815

access-list inbound_connect permit tcp any host 206.x.74.5 eq 1814

access-list inbound_connect permit udp any host 206.x.74.5 eq 45

access-list inbound_connect permit tcp any host 206.x.74.6 eq 5800

access-list inbound_connect permit icmp any any echo

access-list inbound_connect permit icmp any any echo-reply

pager lines 24

interface ethernet0 auto

interface ethernet1 auto

interface ethernet2 auto shutdown

interface ethernet3 auto shutdown

interface ethernet4 auto shutdown

interface ethernet5 auto shutdown

mtu outside 1500

mtu inside 1500

mtu intf2 1500

mtu intf3 1500

mtu intf4 1500

mtu intf5 1500

ip address outside 10.10.x.2 255.255.255.0

ip address inside 206.x.74.1 255.255.255.0

ip address intf2 127.0.0.1 255.255.255.255

ip address intf3 127.0.0.1 255.255.255.255

ip address intf4 127.0.0.1 255.255.255.255

ip address intf5 127.0.0.1 255.255.255.255

ip audit info action alarm

ip audit attack action alarm

no failover

failover timeout 0:00:00

failover poll 15

failover ip address outside 0.0.0.0

failover ip address inside 0.0.0.0

failover ip address intf2 0.0.0.0

failover ip address intf3 0.0.0.0

failover ip address intf4 0.0.0.0

failover ip address intf5 0.0.0.0

pdm history enable

arp timeout 14400

nat (inside) 0 access-list 101

static (inside,outside) 206.x.74.0 206.x.74.0 netmask 255.255.255.0 0 0

access-group inbound_connect in interface outside

route outside 0.0.0.0 0.0.0.0 10.10.10.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si

p 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

no sysopt route dnat

telnet timeout 5

ssh timeout 5

terminal width 80

Cryptochecksum:cbe11c180a955615e6bfe16880d82ac6

: end

[OK]

PixFirewall#

You are welcome ! Since you have these:

access-list 101 permit ip 206.x.74.0 255.255.255.0 206.x.211.0 255.255.255.0

nat (inside) 0 access-list 101

You don't even need the following line:

static (inside,outside) 206.x.74.0 206.x.74.0 netmask 255.255.255.0 0 0

As nat (inside) 0 ACL will come before the static and with nat (0) acl, you are directing the pix not to use the nat engine at all. So, in nutshell, your config looks good.

One thing I suggest is to do "clear xlate" on the pix and see if that ressolves the issue. If not, then my suggesrion would be run syslog on the pix. That will give all the details of whats going on:

logging on

logging buffered debugging

then execute "show logging" that will give you the details of whats going on?

If the pix is pretty busy then logging info on buffer might not be useful (as buffer has limitations on how much it can store) , in that case, you may want to use the syslog to collect the logging info. here is the link on how to do that:

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a0080094030.shtml

I hope this helps ! Thanks,

Mynul