Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

NAC SNMP MAC notification traps not being sent

I have the switch set up for mac notification, and the switch has the below config. But no mac notification traps get sent to the CAM.

interface GigabitEthernet1/0/24

switchport access vlan 800

switchport mode access

snmp trap mac-notification added

spanning-tree portfast

!

snmp-server community **** RO

snmp-server community **** RW

snmp-server enable traps snmp linkdown linkup

snmp-server enable traps MAC-Notification

snmp-server enable traps stpx root-inconsistency loop-inconsistency

snmp-server host 10.101.90.20 version 2c ****

snmp-server host 10.101.90.20 **** MAC-Notification snmp

Below is a debug of snmp packets when a host it connected to the switch on port 1/0/24

1y29w: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/24, changed state to up

1y29w: SNMP: Queuing packet to 10.101.90.20

1y29w: SNMP: V2 Trap, reqid 62, errstat 0, erridx 0

           sysUpTime.0 = 648642685

           snmpTrapOID.0 = snmpTraps.4

           ifIndex.10124 = 10124

           ifDescr.10124 = GigabitEthernet1/0/24

           ifType.10124 = 6

           lifEntry.20.10124 = up

1y29w: SNMP: Queuing packet to 10.101.90.20

1y29w: SNMP: V1 Trap, ent products.516, addr 10.202.1.2, gentrap 3, spectrap 0

           ifIndex.10124 = 10124

           ifDescr.10124 = GigabitEthernet1/0/24

           ifType.10124 = 6

           lifEntry.20.10124 = up

1y29w: SNMP: Packet sent via UDP to 10.101.90.20

1y29w: SNMP: Packet sent via UDP to 10.101.90.20

1y29w: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to up

Am I missing something in the config or something?

Everyone's tags (4)
3 REPLIES

Re: NAC SNMP MAC notification traps not being sent

Hello,

Please post your SNMP receiver config on the CAM. Also, can you do a capture on the CAM to see if you're seeing the packets getting there?

To do the capture, in a SSH session, use this command: tcpdump -ieth0 'host ' -s0 -wcapture.pcap

Once you've captured the success/failure, hit Ctrl-C to kill the capture. You can then use WINSCP or any other SCP program to get that file off of the CAM for further analysis.

HTH,

Faisal

New Member

Re: NAC SNMP MAC notification traps not being sent

I did a tcpdump to the console and The cam was receiving the traps that the switch was sending. The switch is just not sending any mac-notifications. I have screen shots of the snmp reciever config attached

New Member

Re: NAC SNMP MAC notification traps not being sent

fixed it the guy  who configured the switches swapped the read and write strings, and I caught that when adding the switch but he also swapped the v1 and v2 strings. its working now.

3363
Views
4
Helpful
3
Replies