Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nat over GRE tunnel

Hello,

I have this problem regarding a tunnel connection between a Cisco 7200 and a Linux server (2.6.14).

I`ve created the gre tunnel between the 2 servers, I have replies on boths ends. The problem seems to be with NAT. I want to be able to connect to a port on the Cisco interface that will be redirected to the Linux server..

Here is my config:

interface Tunnel0

ip address 172.19.0.2 255.255.255.0

no ip redirects

ip nat inside

tunnel source FastEthernet0/0

tunnel destination Linux

ip nat inside source static tcp 172.19.0.3 22 interface FastEthernet0/0 7200

ip nat outside is specified on the fas0/0 interface.

When I run sh ip nat translations it prints:

Pro Inside global Inside local Outside local Outside global

tcp Cisco:7200 172.19.0.3:22 --- ---

I dont have any acl that would block the connections.

Whats the problem?

2 REPLIES

Re: Nat over GRE tunnel

Hi

Is it possible for you to post out a small topological snapshot of the environment about which you are mentioning over here ??

regds

New Member

Re: Nat over GRE tunnel

Well this is how the interfaces are configured on the cisco 7206VXR (NPE400)

interface Tunnel0

ip address 172.19.0.2 255.255.255.0

no ip redirects

ip nat inside

tunnel source FastEthernet0/0

tunnel destination Linux

!

interface FastEthernet0/0

ip address x.x.218.x 255.255.255.0 secondary

ip address x.x.217.x 255.255.255.240

ip nat outside

ip route-cache same-interface

ip ospf authentication-key passkey

ip ospf priority 200

load-interval 30

duplex full

!

Linux_Server ----tun0---- (fas0/0) Cisco.

I believe that NAT is not enabled or smth.. when I try to connect on fas 0/0 on port 7200 I get connection refused..

I also added this :

ip route 172.19.0.0 255.255.255.0 Tunnel0

350
Views
0
Helpful
2
Replies
CreatePlease to create content