Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

NAT

Hi all,

I am trying to do a NAT translation on R4 so that the packets are sourced from 10.1.1.11.

[r4] -- pix -- [r1]

r4 20.1.24.4 -> 10.1.1.11

So, if I ping to r1 (10.1.1.1) it should see it as sourced from 10.1.1.11 instead of sourced from 20.1.24.4.

R4:

!

interface FastEthernet0/0

ip address 20.x.x.x.x.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 20.1.45.4 255.255.255.0

ip nat outside

duplex auto

speed auto

!

ip nat inside source static 20.1.24.4 10.1.1.11

ip http server

no ip http secure-server

ip classless

ip route 10.1.1.0 255.255.255.0 20.1.24.254

!

R4#debug ip packet

IP packet debugging is on

R4#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

R4#

*Mar 5 01:04:07.647: IP: tableid=0, s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), routed via FIB

*Mar 5 01:04:07.647: IP: s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), len 100, sending

*Mar 5 01:04:07.655: IP: tableid=0, s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), routed via RIB

*Mar 5 01:04:07.655: IP: s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), len 100, rcvd 3

*Mar 5 01:04:07.655: IP: tableid=0, s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), routed via FIB

*Mar 5 01:04:07.655: IP: s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), len 100, sending

*Mar 5 01:04:07.663: IP: tableid=0, s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), routed via RIB

*Mar 5 01:04:07.663: IP: s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), len 100, rcvd 3

*Mar 5 01:04:07.663: IP: tableid=0, s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), routed via FIB

*Mar 5 01:04:07.663: IP: s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), len 100, sending

*Mar 5 01:04:07.671: IP: tableid=0, s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), routed via RIB

*Mar 5 01:04:07.671: IP: s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), len 100, rcvd 3

*Mar 5 01:04:07.671: IP: tableid=0, s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), routed via FIB

*Mar 5 01:04:07.675: IP: s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), len 100, sending

*Mar 5 01:04:07.679: IP: tableid=0, s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), routed via RIB

*Mar 5 01:04:07.679: IP: s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), len 100, rcvd 3

*Mar 5 01:04:07.679: IP: tableid=0, s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), routed via FIB

*Mar 5 01:04:07.683: IP: s=20.1.24.4 (local), d=10.1.1.1 (FastEthernet0/0), len 100, sending

*Mar 5 01:04:07.687: IP: tableid=0, s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), routed via RIB

*Mar 5 01:04:07.687: IP: s=10.1.1.1 (FastEthernet0/0), d=20.1.24.4 (FastEthernet0/0), len 100, rcvd 3

R4#

4 REPLIES
Silver

Re: NAT

Why don't you Nat the address from the PIX firewall? You can use the Global and NAt statements to do this.

New Member

Re: NAT

I don't want to do that. I have a static configured on the PIX firewall.

static (inside, outside) 10.1.1.11 20.1.24.4 netmask 255.255.255.255 0 0

I want to configure NAT on R4 so that the the R1 sees as sourced from 10.1.1.11.

New Member

Re: NAT

may be

interface FastEthernet0/0

ip nat outside

New Member

Re: NAT

Nope it is not working.

113
Views
0
Helpful
4
Replies
CreatePlease to create content