Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help please - Exchange server/PIX

I have installed a PIX firewall instead of our old belkin router, but just cant get my internal exchange server to work right.

the mails are left in a queue with the information: "smtp could not find any DNS server"

That a pretty strange information considering that i have no problem browsing the internet from the server and clients. ive tried to open up for http, smtp and www to get the mailing to work but it seems that i get a DNS problem on the server in return. 192.168.1.200 is the mail server.

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxx

passwd xxx

hostname pixfirewall

domain-name agms

fixup protocol dns maximum-length 4096

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list outside_access_in permit tcp any eq smtp host 83.91.26.149 eq smtp

access-list outside_access_in permit tcp any eq https host 83.91.26.149 eq https

access-list outside_access_in permit tcp any eq www host 83.91.26.149 eq www

access-group outside_access_in in interface outside

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute

ip address inside 192.168.1.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) 192.168.1.200 83.91.26.149 netmask 255.255.255.255 0 0

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.33 inside

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

terminal width 80

Cryptochecksum:xxx

: end

please let me know what you see. ive been trying to get it to work for 3 days. first i was sure that i had made a mistake when trying to open port 25 but my server complain about DNS in the mail queue. thanks in advance

14 REPLIES
Silver

Re: Need help please - Exchange server/PIX

Make the following changes and see what happens...

access-list outside_access_in permit tcp any host 83.91.26.149 eq smtp

access-list outside_access_in permit tcp any host 83.91.26.149 eq https

access-list outside_access_in permit tcp any host 83.91.26.149 eq www

static (inside,outside) 83.91.26.149 192.168.1.200

If this helps,please rate.

Cheers.

Silver

Re: Need help please - Exchange server/PIX

Are you sure that your smtp server service is running?

New Member

Re: Need help please - Exchange server/PIX

yes the service is running because everytime i change the pix with the belkin wireless/router, all problems are gone. but i need VPN support.

jwalker, ill try it first thing tomorrow.

Silver

Re: Need help please - Exchange server/PIX

Hello,

1. Does the exchange have internet connection?

2. Can you try to use the browser or nslookup to see if it can reach the DNS servers.

3. Another thing is try to remove the smpt inspection

no fixup protocol smtp 25

Let me know if the above solves the problem

Regards,

Silver

Re: Need help please - Exchange server/PIX

By the way your access list from outside to inside is incorrect. It should be like this

access-list outside_access_in permit tcp any host 83.91.26.149 eq smtp

access-list outside_access_in permit tcp any host 83.91.26.149 eq https

access-list outside_access_in permit tcp any host 83.91.26.149 eq www

Let me know if this solves the problem,.

Regards,

New Member

Re: Need help please - Exchange server/PIX

okay i will try the access lists.

yes the server has internet access. i tested this by browsing the internet, so DNS is working.

ive talked to the administrator who installed the server and i think the DNS error message might not be accurate. its just an indication that the mail server cannot send or recive. i need to run a few more test today so i can make sure which way is the problem, in or out.

New Member

Re: Need help please - Exchange server/PIX

The access-lists you wrote must be wrong too because if i default the pix im able to brows the internet fine, from ALL clients (192.168.1.x). when i type in this:

access-list outside_access_in permit tcp any host 83.91.26.149 eq www

static (inside,outside) 83.91.26.149 192.168.1.200

OR this:

access-list outside_access_in permit tcp any host 83.91.26.149 eq www

static (inside,outside) 83.91.26.149 192.168.1.200

access-group outside_access_in in interface outside

i can no longer brows anything. as soon as i reverse those two commands, i can brows again.

Silver

Re: Need help please - Exchange server/PIX

To get this to work, you will need to first make the static which translates hosts on a security zone to another security zone..

So

static (inside,outside) 83.91.26.149 192.168.1.200

Then you need to make an access-list, to allow the hosts on the lower sec zone (outside) access to your statically translated host on the inside..

access-list outside_access_in permit tcp any host 83.91.26.149 eq www

Then you need to apply the access-list to the outside interface...

access-group outside_access_in in interface outside

NOTE: This is for inbound traffic ONLY!! If you do not have another ACL on the inside interface (and access group), then ALL traffic will be allowed because it is the highest security zone (without ACLs security zones apply). Also, hosts coming from the outside are only allowed to access 192.168.1.200 using the current ACL. If you need smtp access, then use

access-list outside_access_in permit tcp any host 83.91.26.149 eq smtp

as well...

New Member

Re: Need help please - Exchange server/PIX

yes, so far so good. with these commands im able to recive email (not send) and still brows the network

no fixup protocol smtp n25

access-list outside_in permit tcp any interface outside eq smtp

static (inside,outside) tcp interface smtp 192.168.1.200 smtp netmask 255.255.255.255 0 0

access-group outside_in in interface outside

again, im not able to send mails. its very weird since i have no restrictions outbound. ill paste the whole configuration:

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password upF9MmPO.s3wsSNX encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname pixfirewall

domain-name agms.dk

fixup protocol dns maximum-length 4096

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

no fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list outside_in permit tcp any interface outside eq smtp

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute

ip address inside 192.168.1.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 192.168.1.200 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface smtp 192.168.1.200 smtp netmask 255.255.255.255 0 0

access-group outside_in in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.33 inside

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

terminal width 80

Cryptochecksum:xxxx

: end

pixfirewall#

do you see any problems?

New Member

Re: Need help please - Exchange server/PIX

okay, maybe i should just assume the PIX is bugged and get RMA. i mean, ive never in my 10 years of networking seen so many problems trying to get an exchange server to SEND mail through a firewall from the inside to the outside.

Even with minimal configuration this should be possible, right? by minimum i mean just enough configuration to support all the internal network with internet access and then maybe with the "no fixup protocol smtp 25" added?

The reason why i mention "fixup" is because thats all i ever find trying to google for a solution. it just didnt help me.

Re: Need help please - Exchange server/PIX

Hello,

just a friendly reminder to everyone to please sanitize your configurations before you post them on a public web site such as this. Here we have a config for a PIX that appears to be complete. Having that config is a master key to your security door for anyone that knows what they are doing.

Sorry to be the heavy but it needs to be said

Silver

Re: Need help please - Exchange server/PIX

You may try adding an acl on the inside (that allows all IP) interface to see if that solves the issue..

access-list inside_access permit ip any any

access-group inside_access in interface inside

New Member

Re: Need help please - Exchange server/PIX

thx but i already tried that in my desperation earlier today.

New Member

Re: Need help please - Exchange server/PIX

i finally found the error!

the problem was a misconfigured SMTP DNS IP. on the exchange server, there is a protocol folder where also SMTP has its info. when sending a mail, SMTP is sending 2 quieries using UDP to resolve the domain (hotmail.com, yahoo.com etc.) This IP was set to the internal IP of the gateway (inside address). Somehow the old belkin router resolved this request from the server by default but the pix does not. This IP should not have been set to the inside address, but instead to the ISP external DNS address. as soon as i did that, all mails were send out the PIX.

Thanks all for your help. it was great!

145
Views
10
Helpful
14
Replies
CreatePlease login to create content