Cisco Support Community
Community Member

PIX 501 DHCP-relay

We have a NT 4.0 DHCP-server. We want to use the DHCP-relay in the PIX.

But it doesn't work. When we do

debug dhcprelay event

debug dhcprelay packet

debug dhcprelay error

we get the respons

DHCPRA msg received, fip=, fport=68

DHCPRA: relay binding found for client 0004.ac1a.6e02.

DHCPD: setting giaddr to

DHCPRA: request from 0004.ac1a.6e02 forwarded to

DHCPRA msg received, fip=, fport=67

DHCPD: invalid or unsupported opcode (2).

Any suggestions?


Cisco Employee

Re: PIX 501 DHCP-relay

Check bug CSCea64707, you can't have DHCP relay AND "management-access inside" configured at the same time. If you have that, remove the command or call the TAC and they can provide you a fixed version of code.

Community Member

Re: PIX 501 DHCP-relay


We have tried to swith off the management access, and it works. Now we just have to find the 6.3(1.100) release which is the one with this case solved. I'll get back with info if that version really (I don't believe it until I see it) solves the problem.


Cisco Employee

Re: PIX 501 DHCP-relay

Heh heh, have some faith :-)

Call the tAC and they'll be able to give you the code. It's an interim version so it won't be available on CCO ever. All the changes in this and the other interim versions will eventually be rolled into 6.3(2), so you can then upgrade to that when it comes out later if you prefer to be running a release version.

Community Member

Re: PIX 501 DHCP-relay


It's now working. We have been trying to solve this problem for at least 5-6 weeks, and it turns out that it was a BUG...

You may mark this conversation as solved.


CreatePlease to create content