Cisco Support Community
Community Member

PIX 501 NAT Configuration

Our ISP has supplied us with a Cisco router that is configured to forward email messages to the exchange server on our network. I called and told them that I am adding a firewall and they told me that they need to disable NAT on their router and that the firewall will need to be configured to handle this. Below is configuration of the router. How do I enable the firewall so that it will forward the messages to the exchange server once the NAT is disabled on the router. I have read throught the configuration guide and I can't figure out how to set this up. Thanks.

Current configuration for ISP's Cisco Router

ip subnet-zero

ip name-server

ip name-server

ip name-server


ip dhcp pool lan1






interface Serial0

ip address

no ip directed-broadcast

ip nat outside

encapsulation ppp

no fair-queue

service-module t1 timeslots 13-24


interface FastEthernet0

ip address xx.xx.xx.54 secondary

ip address

no ip directed-broadcast

ip nat inside


ip nat inside source list 1 interface Serial0 overload

ip nat inside source static tcp 25 25 extendable

ip nat inside source static tcp 110 110 extendable

ip classless

ip route Serial0

ip route

no ip http server


access-list 1 permit

Current configuration for PIX Firewall

PIX Version 6.3(1)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxxx encrypted

passwd xxxx encrypted

clock timezone CST -6

clock summer-time CDT recurring

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521


pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside

ip address inside

ip audit info action alarm

ip audit attack action alarm

pdm location inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0 0

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet timeout 5

ssh timeout 5

console timeout 0

terminal width 80


: end

Community Member

Re: PIX 501 NAT Configuration

Will adding these lines work?

static (outside,inside) netmask 0 0

static (inside,outside) netmask 0 0


Re: PIX 501 NAT Configuration

This should do the trick...

static (inside,outside) netmask 1000 500


access-list outside_in permit tcp any host eq smtp


access-group outside_in in interface outside

If you have remote users that pop in to get there mail, your going to need this line also..

access-list outside_in permit tcp any host eq pop3

Hope that helps.

CreatePlease to create content