Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

Pix 501 password recovery problem

Hello everyone!

I just bought a second hand PiX 501. Of course it is passwd protected, not a problem actually.

But then my problem came, the standard password recovery procedure does NOT work!

My bios rewision is 4.2, so i chose nppix.bin from the password overrider files.

My tftp server is up and running! And it is even sharing the file! The download of the file completes to the PiX!

It is just, that after the download, i get xxxxxx bytes downloaded successfully, and then nothing.

No question for resetting the passwd, no prompt, no reboot.

Actually even my terminal says i'm off-line!

I use debian 5 with minicom as terminal.

I could use any help!

( ps.: i tought, i must be using the wrong file, so tried them all... I even downloaded them at the company i work for. I tought maybe my proxy at home is crushing the file. But no luck. i casted diff on the two files, and they are identical. )

Thanks in advance!

Tamas Makovenyi

Cisco Employee

Re: Pix 501 password recovery problem

Hi Tamas,

I read over the problem that you have. It sounds like you are just trying to get access to it again since you had bought it from someone.  Have you tried to erase the flash and then load in a new code into the pix?  You have to use the erasedisk first through monitor mode.. it will allow you to erase the flash including the config and the activation keys..  so you will have to add your key back in and build the config from scratch.

After you run that and erase the flash, you repeat by going back into the monitor mode and then you can tftp the image over for your pix.

Erase disk can be downloaded:

You can download the new pix code:

hope that helps a bit..  again this will erase the flash and you can then re-image the pix.  this will remove everything from the pix including the config and activation key.



Community Member

Re: Pix 501 password recovery problem

Hello Scott!

Thanks for your repply.

Actually my problem was, that while turning on the device showed a version

of software.

I tried to use the np.bin for that version. It did not work, so i tried all

of the bins. Except one...

Than a admin friend of mine told me that i shall let it stand up completely,

because he is not sure, that the version of os is what i think.

And after standing up, the version was a different one.

Exactly that one which i missed to try... ( i only knew this when it worked


But your post is a nice to know thread!!!

Thank you very much!

Best Regards

Tamás Makovényi

2010/8/25 snishimu

Makovenyi Tamas,


A new message was posted in the Discussion thread "Pix 501 password

recovery problem":



Author : Scott Nishimura

Profile :



Cisco Employee

Re: Pix 501 password recovery problem

Hi Tamas,

sounds good.. glad you got it recovered.


CreatePlease to create content