Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

PIX 501 Site to Site VPN Help

Hi,

I'm pretty new to PIX firewalls, so I hope that somebody on here can assist me.

I have two PIXs and am trying to create a VPN between the two PIX. I have posted the configs below.

The problem lies that on PIX One I can ping PIX Two, but I can't ping any servers behind PIX TWO. On PIX Two I can't ping PIX ONE or any servers behind it.

Any advise would be appreciated.

Thanks

PIX ONE

PIX Version 6.2(2)

nameif ethernet0 outside security0

nameif ethernet1 inside security100

hostname TMAXWALES

domain-name ciscopix.com

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list inside_outbound_nat0_acl permit ip 192.168.254.0 255.255.255.0 192.1

68.1.0 255.255.255.0

access-list outside_cryptomap_20 permit ip 192.168.254.0 255.255.255.0 192.168.1

.0 255.255.255.0

pager lines 24

interface ethernet0 10baset

interface ethernet1 10full

mtu outside 1500

mtu inside 1500

ip address outside ***.*.198.139 255.255.255.248

ip address inside 192.168.254.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 192.168.254.10 255.255.255.255 inside

pdm location 192.168.1.0 255.255.255.0 outside

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 ***.*.198.137 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si

p 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 192.168.254.10 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

no sysopt route dnat

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto map outside_map 20 ipsec-isakmp

crypto map outside_map 20 match address outside_cryptomap_20

crypto map outside_map 20 set peer ***.*.198.138

crypto map outside_map 20 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

isakmp enable outside

isakmp key ******** address ***.*.198.138 netmask 255.255.255.255 no-xauth no-co

nfig-mode

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash sha

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet timeout 5

ssh timeout 5

terminal width 80

PIX TWO

PIX Version 6.2(2)

nameif ethernet0 outside security0

nameif ethernet1 inside security100

hostname tmaxbangor

domain-name ciscopix.com

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168

.254.0 255.255.255.0

access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 192.168.254

.0 255.255.255.0

pager lines 24

logging on

logging buffered debugging

interface ethernet0 10baset

interface ethernet1 10full

mtu outside 1500

mtu inside 1500

ip address outside ***.*.198.138 255.255.255.248

ip address inside 192.168.1.1 255.255.255.0

ip verify reverse-path interface outside

ip verify reverse-path interface inside

ip audit info action alarm drop reset

ip audit attack action alarm drop reset

pdm location 192.168.1.0 255.255.255.0 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 ***.*.198.137 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si

p 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.84.7.111 255.255.255.255 inside

http 192.168.1.10 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

no sysopt route dnat

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto map outside_map 20 ipsec-isakmp

crypto map outside_map 20 match address outside_cryptomap_20

crypto map outside_map 20 set peer ***.*.198.139

crypto map outside_map 20 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

isakmp enable outside

isakmp key ******** address ***.*.198.139 netmask 255.255.255.255 no-xauth no-co

nfig-mode

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash sha

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet 192.168.1.0 255.255.255.0 inside

telnet timeout 50

ssh timeout 5

terminal width 80

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: PIX 501 Site to Site VPN Help

Can't see anything obviously wrong with the configs. Do you have these connected back to back on the same subnet, it looks like it even though you've xxx'd out the IP addresses? If so it might just be a routing issue, in that they're sending everything to the default gateway of xxx.x.198.137 rather than to each other.

Try adding a static route for the remote subnet into each PIX that directly points to the peer, so on PIX1 you'd have:

route outside 192.168.1.0 255.255.255.0 xxx.x.198.138

and on PIX2 do:

route outside 192.168.254.0 255.255.255.0 xxx.x.198.139

and see if that makes any difference. Note that you wouldn't run into this issue when both PIX's are on separate networks and use their default gateway for all their routing decisions.

If that still fails, run "debug cryp isa" and "debug cry ipsec" on both PIX's and then try and build a tunnel again, then send us the output.

Also, make sure in your testing that you're pinging from a host behind one PIX to a host behind the other PIX, don't ping from PIX to PIX or from host to PIX cause that won't test your VPN connectivity.

1 REPLY
Cisco Employee

Re: PIX 501 Site to Site VPN Help

Can't see anything obviously wrong with the configs. Do you have these connected back to back on the same subnet, it looks like it even though you've xxx'd out the IP addresses? If so it might just be a routing issue, in that they're sending everything to the default gateway of xxx.x.198.137 rather than to each other.

Try adding a static route for the remote subnet into each PIX that directly points to the peer, so on PIX1 you'd have:

route outside 192.168.1.0 255.255.255.0 xxx.x.198.138

and on PIX2 do:

route outside 192.168.254.0 255.255.255.0 xxx.x.198.139

and see if that makes any difference. Note that you wouldn't run into this issue when both PIX's are on separate networks and use their default gateway for all their routing decisions.

If that still fails, run "debug cryp isa" and "debug cry ipsec" on both PIX's and then try and build a tunnel again, then send us the output.

Also, make sure in your testing that you're pinging from a host behind one PIX to a host behind the other PIX, don't ping from PIX to PIX or from host to PIX cause that won't test your VPN connectivity.

118
Views
0
Helpful
1
Replies
CreatePlease to create content