Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PIX 501 with Cable Modem

I want to Connect a Pix 501 to my Cable Modem, but when I connect the crossover cable, I get NO Link light. If I connect a standard patch cable to the cable modem, I get a link light, but still no connectivity from the firewall to the outside world. What did I miss?

5 REPLIES

Re: PIX 501 with Cable Modem

Fist you need to have a link !

Do a < show interface > and verify the link speed and duplex mode.

Configure the interface to < auto > if this does not work try to change to 10 or 100 and Half and Full Duplex.

interface ethernet0 auto

interface ethernet1 auto

sincerely

Patrick

New Member

Re: PIX 501 with Cable Modem

When the crossover cable is connected, I get no link.

When a straight thru patch cable is plugged in a get a link. Below is my interface settings.

PIX Version 6.3(1)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

Re: PIX 501 with Cable Modem

Can you please post the config (wr t) and < show interface > output.

Remove the public IP and replace it with x.x.x.1 and Password section.

Note that usually it is a straight cable ! You have a link so it is ok.

Do you use DHCP or static IP ?

sincerely

Patrick

New Member

Re: PIX 501 with Cable Modem

Static IP Address

Thanks for the help.

PIX Version 6.3(1)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxx

passwd xxxx

hostname barberpix

domain-name barberatty.com

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

names

mtu outside 1500

mtu inside 1500

ip address outside x.x.x.1 255.255.255.252

ip address inside 192.168.10.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

route outside 0.0.0.0 0.0.0.0 x.x.x.1 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 192.168.10.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.10.2-192.168.10.33 inside

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

dhcpd enable inside

terminal width 80

barberpix#

Re: PIX 501 with Cable Modem

You miss the NAT command in your config.

I hope that:

route outside 0.0.0.0 0.0.0.0 x.x.x.1 1

ip address outside x.x.x.1 255.255.255.252

Use nothe same public IP ? ==> x.x.x.1 default gateway should be diffrent than external IP.

You miss a following line:

nat (inside) 1 192.168.10.0 255.255.255.0 0 0

clear xlate

sincerely

Patrick

214
Views
0
Helpful
5
Replies