Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PIX 520 Upgrade.

We have a PIX 520 being used solely for SMTP connectivity to another City Agency. We are running at v4.3xx. Currently trying to upgrade to at least v 5.x. Create a RAWRITE floopy with the BH files on Bootup the firewall says "Executing Floppy" and keeps doing that in cycles and we never get to the Bootable image.

I have tried the floppy on another PIX and works like a charm.

My question is how do we get to fix this issue, Cisco says in FAQ use another PC to create BOOT HELPER file but the floopy works fine on other PIX's.

Any suggestions.

Thanks in Advance

Khalid

4 REPLIES
New Member

Re: PIX 520 Upgrade.

How much flash and RAM do you have installed? What was the other PIX model you tried it on? Did you load the new PIX OS into flash yet?

I have a PIX 520, if you let me know your specifics, I may be able to help.

New Member

Re: PIX 520 Upgrade.

Thanks for the response. The machine has 128 Meg memory and 16 Meg Flash.

Similiar Configs on the machine that boots up fine from the floppy.

The PIX OS never gets to the flash it keeps trying to load from floppy and goes in circles once in a while will say Loading Boot Loader and then hangs.

I have swapped the floopy and get exactly the same results so thats out.

Any suggestions.

Sincerly

New Member

Re: PIX 520 Upgrade.

Wow! You got me stumped on that last one. You're right, if the diskette works on the other PIX-520, then it's definitely OK. Have you opened a case with TAC on this? I suspect either a setting in flash or on the system board that is configured differently between the two.

You could try comparing any jumper or DIP switch settings that you may see on both of the PIXs. Be sure to write down the original settings so you know where you started...

After that, I would try to move the flash from the PIX you are trying to upgrade over to the PIX that runs the helper diskette OK. From there, you should be able to upgrade the flash to the new level, verify that it works OK, and then move it back over to the original PIX.

Remember that for normal operation you don't boot off the helper diskette.

Not sure if that helps or not. Sounds like you've got something going on that I've never seen before. If anything, I'd suspect either the settings I mentioned above, or some type of hardware failure on the system board itself...

New Member

Re: PIX 520 Upgrade.

I am not sure if this helps :

Some time back I am trying to upgrade my PIX 520 at 4.2(4) to a higher version.

The first floopy I tried is a 5.3(2) boothelper, which keeps restarting the pix,

much like what you are encountering. I can't remember how, but I think manage

to catch a error manage say it don't recognise the flash memory or have some

problem with it etc.........

Later I figured out that it is complaining it doesn't support the flash I am using

(only 2MB of flash) and so I use 5.1 instead. That boots up just fine and I upgraded

it to 5.1(5). That 5.3(2) floopy boots up just fine on a PIX 520 with 16 MB ram.

109
Views
0
Helpful
4
Replies
CreatePlease to create content