Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Pix 7.2(1) RDP sessions dropping with a TCP Reset-O

I've got some users connecting over RDP to internal windows hosts, they're getting regular intermittent timeouts, i've checked my logs and it looks like the connections being torn down with a tcp reset-O on the end.

Jul 24 13:15:56 10.0.1.1 Jul 24 2006 12:18:16: %PIX-6-302014: Teardown TCP connection 605272 for outside:External-Office/1283 to Dev:internal-host/3389 duration 0:08:45 bytes 152790 TCP Reset-O

Jul 24 13:15:56 10.0.1.1 Jul 24 2006 12:18:16: %PIX-6-106015: Deny TCP (no connection) from External-Office/1283 to ext-internal-Host/3389 flags PSH ACK on interface outside

That's as much as i can get from the logs, unfortunately not enough to resolve the problem, can anyone shed some light on the tcp reset-o and suggest what's happening, and even better, a fix! :)

Thanks in advance

Richard

2 REPLIES
New Member

Re: Pix 7.2(1) RDP sessions dropping with a TCP Reset-O

Are you saying RDP does actually work ok, but getting the odd timeouts or slow connections within the rdp session? Reset-O is saying, the outside end disconnected the session, possibly due to slow response to the server? or loss session connection. What is the speed of the connection?

New Member

Re: Pix 7.2(1) RDP sessions dropping with a TCP Reset-O

Yeah initially it's fine, but after a variable amount of time it'll disconnect, from the user's end it'll flash the network icon on the rdp session as if the connection was lost.

These problems only started when I upgraded my pix's to 7.2(1) from 7.0. I'm wondering if since the upgrade they're less tolerant to a troubled connection.

My servers are in London on a 100meg line and the users are in central Russia.... so yeah, it's entirely possible it's down to the distance between. But I can't change that variable. So i'm hoping I can tweak something at my end to fix it.

723
Views
0
Helpful
2
Replies
CreatePlease to create content