Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PIX to PIX- VPN Wizard

I have 2 PIX firewalls and ran the VPN wizard to setup a VPN tunnel. I am not well versed with Cisco products but I know the basics. Anyways, both Pix's show on the homepage under VPN status that I have 1 IPSec and 1 IKE tunnel. However, I cannot ping between the networks and no traffic is flowing between the 2 networks. I am thinking that I need to setup the ACL's but I would think the VPN wizard would of guided me through it. Is that what I am missing you think? What else can I troubleshoot? Please Advise. Thanks

11 REPLIES
New Member

Re: PIX to PIX- VPN Wizard

If you do a debug crypto ipsec and a debug crypto isakmp from the command line it should give you enough information for you to figure out if the tunnel has been successfully established. You can also do a show crypto ipsec sa and look at the #pkts encaps decaps to see if they are encapsulating and decaupsulating properly.

If you didnt sent up access lists then there might not be a security association that the firewalls agree to. It definitely needs an access list because you are specifying what traffic and what networks you want to cross the tuneel. You also need to make sure that you except the traffic from the nat process. You need a nat 0 statement for what ever access list you create.

Is it possible for you to telnet into the pix firewalls and tftp the configs and then upload on here. Or you can copy and paste..whichever is easier for you.

New Member

Re: PIX to PIX- VPN Wizard

Here is the config from one of them. It looks like the 'Tampa' entry just shows the subnet and not the IP. Take a look.

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

no fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

name 10.10.12.3 TerminalServer

name 10.10.12.2 MainServer

name 10.10.12.5 Equitrac

name 192.168.1.0 Tampa

object-group service MailServerices tcp

port-object eq www

port-object eq pop3

port-object eq https

port-object eq smtp

port-object eq imap4

object-group service RDP tcp

port-object range 3389 3389

access-list outside_access_in permit tcp any host 74.228.x.x object-group Mail

Serverices

access-list outside_access_in permit ip 64.40.x.x 255.255.255.192 any

access-list outside_access_in permit icmp any any

access-list outside_access_in permit tcp any host 74.228.x.xobject-group RDP

access-list outside_access_in permit tcp any host 74.228.x.x object-group RDP

access-list outside_access_in permit tcp any host 74.228.x.x eq pcanywhere-dat

a

access-list outside_access_in permit udp any host 74.228.x.x eq pcanywhere-sta

tus

access-list inside_outbound_nat0_acl permit ip 10.10.12.0 255.255.255.0 Tampa 25

5.255.255.0

access-list outside_cryptomap_20 permit ip 10.10.12.0 255.255.255.0 Tampa 255.25

5.255.0

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 74.228.x.x 255.255.255.248

ip address inside 10.10.12.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 64.40.x.x 255.255.255.192 outside

pdm location MainServer 255.255.255.255 inside

pdm location TerminalServer 255.255.255.255 inside

pdm location 64.40.x.x 255.255.240.0 outside

pdm location Equitrac 255.255.255.255 inside

pdm location Tampa 255.255.255.0 outside

pdm history enable

arp timeout 14400

global (outside) 10 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 10 0.0.0.0 0.0.0.0 0 0

static (inside,outside) 74.228.x.x MainServer netmask 255.255.255.255 0 0

static (inside,outside) 74.228.x.x TerminalServer netmask 255.255.255.255 0 0

static (inside,outside) 74.228.x.x Equitrac netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 74.228.x.x 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 64.40.128.0 255.255.240.0 outside

http 0.0.0.0 0.0.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto map outside_map 20 ipsec-isakmp

crypto map outside_map 20 match address outside_cryptomap_20

crypto map outside_map 20 set peer 24.227.x.x

crypto map outside_map 20 set transform-set ESP-3DES-MD5

crypto map outside_map interface outside

isakmp enable outside

isakmp key ******** address 24.227.x.x netmask 255.255.255.255 no-xauth no-con

fig-mode

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet 0.0.0.0 0.0.0.0 inside

telnet timeout 5

ssh 64.40.128.0 255.255.240.0 outside

ssh timeout 5

console timeout 0

terminal width 80

Cryptochecksum:12070fead46722a9a89dbfef96177d1c

New Member

Re: PIX to PIX- VPN Wizard

This config looks fine. I don't see anything wrong with it. Can you post the other config as well?

New Member

Re: PIX to PIX- VPN Wizard

shouldnt it show the tampa network instead of just the subnet mask? The .12 network in miami which is the config I posted.

access-list inside_outbound_nat0_acl permit ip 10.10.12.0 255.255.255.0 Tampa 25

5.255.255.0

access-list outside_cryptomap_20 permit ip 10.10.12.0 255.255.255.0 Tampa 255.25

5.255.0

New Member

Re: PIX to PIX- VPN Wizard

It does show the tampa network. the "Tampa" in your access list refers to that network 1and the subnet you see is a class C for it. You can find that if you look at the "name" entries you have in the config

Cisco Employee

Re: PIX to PIX- VPN Wizard

Hello,

What is the destination IP Addres that you are trying to ping and where are you sourcing the packet from.

Try to ping from a host on the 10.10.12.x to 192.168.1.x and do not ping from the pix firewall to test the VPN Tunnel Connectivity.

And also, can u do a clear xlate on the pix and then do the ping test.

Make sure the configuration on the other pix and routing is good.

If you are still having issue, please do post the outputs of "show crypto isakmp sa" and "show crypto ipsec sa".

Regards,

Arul

New Member

Re: PIX to PIX- VPN Wizard

I will try that tomorrow and post my findings here. Thanks guys.

New Member

Re: PIX to PIX- VPN Wizard

here is the tampa config...

User Access Verification

Password:

Password:

Password:

Type help or '?' for a list of available commands.

HMB-Tampa> en

Password: ********

HMB-Tampa# show config

: Saved

: Written by enable_15 at 12:22:43.076 UTC Sun Sep 10 2006

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxx

passwd xxx

hostname HMB-Tampa

domain-name hamiltonmiller.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

name 192.168.1.5 Workstation

name 10.10.12.0 Miami

object-group service RDP tcp

port-object range 3389 3389

access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 Miami 2

55.255.255.0

access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 Miami 255.2

55.255.0

access-list inside_access_in permit ip interface inside any

access-list inside_access_in permit ip any any

access-list inside_access_in permit ip interface inside Miami 255.255.255.0

access-list outside_access_in permit tcp any host 24.227.81.54 object-group RDP

access-list outside_access_in permit icmp any any

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 24.x.x.52 255.255.255.248

ip address inside 192.168.1.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location Workstation 255.255.255.255 inside

pdm location Miami 255.255.255.0 outside

pdm location 192.168.1.0 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) 24.x.x.54 Workstation netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside

access-group inside_access_in in interface inside

route outside 0.0.0.0 0.0.x.x.227.81.49 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto map outside_map 20 ipsec-isakmp

crypto map outside_map 20 match address outside_cryptomap_20

crypto map outside_map 20 set peer 74.228.10.18

crypto map outside_map 20 set transform-set ESP-3DES-MD5

crypto map outside_map interface outside

isakmp enable outside

isakmp key ******** address 74.x.x.18 netmask 255.255.255.255 no-xauth no-con

fig-mode

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

telnet 192.168.1.0 255.255.255.255 inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.10-192.168.1.30 inside

dhcpd dns 65.32.x.x.32.1.65

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

dhcpd enable inside

terminal width 80

Cryptochecksum:xxxx

HMB-Tampa#

New Member

Re: PIX to PIX- VPN Wizard

I dont see an access-group applied to the inside interface on the miami firewall. Where is it? It seems like this can be the cause of your problem. Try adding the following.

access-list inside_access_out permit icmp any any

access-group inside_access_out in interface inside

New Member

Re: PIX to PIX- VPN Wizard

Once I added thr ACL's to both Pix's, I was able to ping back and forth. The ACL's were the issue. Thanks for everything guys.

New Member

Re: PIX to PIX- VPN Wizard

Can you clarify what acl's they were?

175
Views
0
Helpful
11
Replies
CreatePlease login to create content