Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PIX VPN for remote users

We have a site to site VPN tunnel that is function correctly and need to add the ability for remote users to also VPN into the PIX firewall. We will be using the Cisco VPN 4.0 client. Here is my current configuration with my attempt to allow the remote users access.

PIX Version 6.3(1)

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password FvVkYX17HGej6to6 encrypted

passwd Tip1D3fx0WMya/Kv encrypted

hostname pixfirewall

domain-name ciscopix.com

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

names

access-list 90 permit ip 10.1.1.0 255.255.255.0 192.168.111.0 255.255.255.0

access-list icmp_traffic permit icmp any any unreachable

access-list icmp_traffic permit icmp any any echo-reply

access-list icmp_traffic permit icmp any any time-exceeded

access-list remote permit ip host 10.1.1.0 any

pager lines 24

logging on

logging timestamp

logging trap errors

logging host inside 10.1.1.11

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute

ip address inside 10.1.1.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 10.1.1.11 255.255.255.255 inside

pdm location 192.168.111.0 255.255.255.0 outside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list 90

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

access-group icmp_traffic in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 10.1.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set strong esp-3des esp-sha-hmac

crypto dynamic-map dyn 20 match address remote

crypto dynamic-map dyn 20 set pfs group2

crypto dynamic-map dyn 20 set transform-set strong

crypto map vpn 10 ipsec-isakmp

crypto map vpn 10 match address 90

crypto map vpn 10 set pfs group2

crypto map vpn 10 set peer 68.73.xx.xx

crypto map vpn 10 set transform-set strong

crypto map vpn 20 ipsec-isakmp dynamic dyn

crypto map vpn interface outside

isakmp enable outside

isakmp key ********** address 68.73.xx.xx netmask 255.255.255.255

isakmp identity address

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash sha

isakmp policy 10 group 2

isakmp policy 10 lifetime 3600

telnet timeout 5

ssh 0.0.0.0 0.0.0.0 inside

ssh timeout 60

console timeout 0

dhcpd address 10.1.1.2-10.1.1.10 inside

dhcpd lease 3600000

dhcpd ping_timeout 750

dhcpd auto_config outside

dhcpd enable inside

terminal width 80

1 REPLY
New Member

Re: PIX VPN for remote users

Hi,

This is the configuration for remote users coming into the PIX, and the client 4.0:

http://www.cisco.com/warp/public/110/pix3000.html

This is with external authentication:

http://www.cisco.com/warp/public/110/cvpn3k_pix_ias.html

The only thing missing is the ip local pool and vpngroup commands.

79
Views
0
Helpful
1
Replies
CreatePlease login to create content